summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-05-18 16:40:50 +0100
committerMarek Szuba <marecki@gentoo.org>2018-05-18 16:57:07 +0100
commit30fa5ca9f414b0c9581b93b34247f189fa504628 (patch)
tree27304d95f643c83500ea003cbb2c8cf2bd8e2730 /games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild
parentsci-physics/geant: choose right tls model with USE=threads (diff)
downloadgentoo-30fa5ca9f414b0c9581b93b34247f189fa504628.tar.gz
gentoo-30fa5ca9f414b0c9581b93b34247f189fa504628.tar.bz2
gentoo-30fa5ca9f414b0c9581b93b34247f189fa504628.zip
games-action/shadowgrounds-bin: update hash
Had to change the version number in the process because of what is currently available for Linux from HumbleBundle.com. No other changes and no mask removal because chances are this package will still get removed. Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild')
-rw-r--r--games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild
new file mode 100644
index 000000000000..3a8863f6bb90
--- /dev/null
+++ b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_p1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit unpacker games eutils versionator
+
+DIST_PV=$(get_version_component_range 2)
+
+DESCRIPTION="an epic action experience combining modern technology with addictive playability"
+HOMEPAGE="http://shadowgroundsgame.com/"
+# FIXME: PV should perhaps be 0_p1, in which case a filter is in order
+SRC_URI="shadowgroundsUpdate${DIST_PV/p/}.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/glibc-2.4
+ >=sys-devel/gcc-4.3.0
+ !amd64? (
+ gnome-base/libglade
+ sys-libs/zlib
+ )
+ amd64? (
+ >=gnome-base/libglade-2.6.4-r1[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ )"
+
+S=${WORKDIR}
+
+d="${GAMES_PREFIX_OPT}/${PN}"
+QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
+QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unpack_zip ${A}
+ rm lib*/lib{gcc_s,m,rt,selinux,z}.so.?
+}
+
+src_install() {
+ local b bb
+
+ doicon Shadowgrounds.xpm
+ for b in bin launcher ; do
+ bb="shadowgrounds-${b}"
+ exeinto ${d}
+ newexe ${bb} ${bb} || die
+ games_make_wrapper ${bb} "./${bb}" "${d}"
+ make_desktop_entry ${bb} "Shadowgrounds ${b}" Shadowgrounds
+ done
+
+ exeinto ${d}/lib32
+ doexe lib32/*
+
+ insinto ${d}
+ doins -r Config data Profiles *.fbz *.glade *-logo.png
+
+ prepgamesdirs
+}