summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/snipes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/snipes')
-rw-r--r--games-action/snipes/Manifest1
-rw-r--r--games-action/snipes/files/snipes-1.0.4-nongnulinker.patch20
-rw-r--r--games-action/snipes/metadata.xml5
-rw-r--r--games-action/snipes/snipes-1.0.4.ebuild36
4 files changed, 62 insertions, 0 deletions
diff --git a/games-action/snipes/Manifest b/games-action/snipes/Manifest
new file mode 100644
index 000000000000..5876f6ffc3e4
--- /dev/null
+++ b/games-action/snipes/Manifest
@@ -0,0 +1 @@
+DIST snipes-1.0.4.tar.gz 39150 SHA256 61096e82e2467e3b8ada0560e08d0745022cfe674cdf333e2ee7e140e841a913 SHA512 de2cfdc3062055bfd04766f11894786af2ccd57ee1c8bcfe28d2d6894fe543830061ad7d16fa5e0363a25dcfd4a4c297ec0b81e449392a7b2b7d65da2e2a2f9b WHIRLPOOL 38c801035217a68ee43a209011fd17f66a4acace1e3f6896984aa9e9242366c897a344d35c4775a20b6439f16b098569156718f720c11b2c1f30bf616615abc5
diff --git a/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch b/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch
new file mode 100644
index 000000000000..dbfab286e4b0
--- /dev/null
+++ b/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch
@@ -0,0 +1,20 @@
+--- Makefile.old 2011-12-18 17:24:28.795315064 +0100
++++ Makefile 2011-12-18 17:24:59.005311478 +0100
+@@ -33,7 +33,7 @@
+ IMGOBJ = $(OIMGS:%.pbm=$(INTERMEDIATE)/%.o)
+
+ CFLAGS += `sdl-config --cflags` -I$(INTERMEDIATE)
+-LDLIBS += `sdl-config --libs`
++LDLIBS += `sdl-config --libs` -lm
+ LDFLAGS += -Wl,-z,noexecstack
+
+
+@@ -52,7 +52,7 @@
+
+ # Why does this result in an executable stack? Can I run my bitmaps? Do bitmaps behave like Conway's game of life, when run?
+ $(INTERMEDIATE)/%.o: $(IMG)/%.pbm
+- $(LD) -r -b binary -z noexecstack -z really_noexecstack -z pretty_please_noexecstack -o $@ $<
++ $(LD) -r -b binary -z noexecstack -o $@ $<
+
+ snipes.6: snipes.6.in
+ sed s/'`VERSION`'/`cat VERSION`/ < $< > $@
diff --git a/games-action/snipes/metadata.xml b/games-action/snipes/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/snipes/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/snipes/snipes-1.0.4.ebuild b/games-action/snipes/snipes-1.0.4.ebuild
new file mode 100644
index 000000000000..8cf7db015be2
--- /dev/null
+++ b/games-action/snipes/snipes-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs eutils games
+
+DESCRIPTION="2D scrolling shooter, resembles the old DOS game of same name"
+HOMEPAGE="http://cyp.github.com/snipes/"
+SRC_URI="http://cyp.github.com/snipes/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nongnulinker.patch
+}
+
+src_compile() {
+ tc-getLD
+ default
+}
+
+src_install() {
+ dogamesbin snipes
+ doman snipes.6
+ dodoc ChangeLog
+ doicon ${PN}.png
+ make_desktop_entry snipes "Snipes"
+ prepgamesdirs
+}