summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/solar2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/solar2')
-rw-r--r--games-action/solar2/Manifest2
-rw-r--r--games-action/solar2/metadata.xml11
-rw-r--r--games-action/solar2/solar2-1.10.ebuild106
3 files changed, 119 insertions, 0 deletions
diff --git a/games-action/solar2/Manifest b/games-action/solar2/Manifest
new file mode 100644
index 000000000000..00928ef42962
--- /dev/null
+++ b/games-action/solar2/Manifest
@@ -0,0 +1,2 @@
+DIST solar2-linux-1.10.tar.gz 106202569 SHA256 33211605946741db730082478c4a408547a89facfc2e3535b124c6706809d8b2 SHA512 68475cfe9220a1f19608cd2dfb575979e231dcf1bc61e12230db5a39856a03afceeb8c3f2b0ea6d958b36a53945bdb2768261f2b0bcc50a88f2b3eeddc48df9d WHIRLPOOL 86d0ed2c7a28e498323949e871f7ba8f1714f39f98ab625f6dddb0249af7c1e653264ebc4b76cc9be5579f99395e2c578363effcd2c97bb27690b05ec4e73a4e
+DIST solar2.png 6478 SHA256 ab62168651de322dc68a9094baf1ba92524d2d9e76b1650eef60527cd7e3f611 SHA512 b1110d19d62274ac90391f9611fc8efaa1c2ca70cf62f146969768ed2dd76e013054b1a9dfdb123b56536f5ba7788971747219485811eeb6652f22e0867348d9 WHIRLPOOL 358a3fb56c13710abf4ac3115c968579c787ed67f4c8672e0236ce379a56d6540f8c5ad6f8ca16370c0b080ae2763ec2256cbcd1ff2bb0765a7dc5164fc39972
diff --git a/games-action/solar2/metadata.xml b/games-action/solar2/metadata.xml
new file mode 100644
index 000000000000..d13413d31d91
--- /dev/null
+++ b/games-action/solar2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
+
diff --git a/games-action/solar2/solar2-1.10.ebuild b/games-action/solar2/solar2-1.10.ebuild
new file mode 100644
index 000000000000..8936a03a9fca
--- /dev/null
+++ b/games-action/solar2/solar2-1.10.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: - unbundle libmono for 64bit
+# - unbundling libSDL_mixer breaks the game
+# - provide icon
+# - test useflags for libsdl on x86
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="An open-world, sandbox game set in an infinite abstract universe"
+HOMEPAGE="http://murudai.com/solar/"
+GAMEBALL="${PN}-linux-${PV}.tar.gz"
+ICONFILE="http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+SRC_URI="${GAMEBALL} ${ICONFILE}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/Solar2.bin.x86"
+
+RDEPEND="
+ virtual/opengl
+ amd64? (
+ >=media-libs/flac-1.2.1-r5[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,sound,video,joystick,abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ !bundled-libs? (
+ >=media-libs/libmad-0.15.1b-r8[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ >=media-libs/sdl-mixer-1.2.12-r4[flac,mikmod,mad,mp3,vorbis,abi_x86_32(-)]
+ >=media-libs/libmikmod-3.2.0[abi_x86_32(-)]
+ )
+ )
+ x86? (
+ media-libs/flac
+ media-libs/libsdl[X,sound,video,joystick]
+ media-libs/libvorbis
+ !bundled-libs? (
+ dev-lang/mono
+ media-libs/libmad
+ media-libs/libmikmod
+ media-libs/openal
+ media-libs/sdl-mixer[flac,mikmod,mad,mp3,vorbis]
+ )
+ )"
+
+S=${WORKDIR}/Solar2
+
+pkg_nofetch() {
+ einfo "Please buy & download ${GAMEBALL} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "Also download ${ICONFILE}"
+ einfo "and move both to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ # remove unused files
+ rm solar2.sh || die
+
+ if ! use bundled-libs ; then
+ einfo "Removing bundled libs..."
+ if use amd64 ; then
+ # no mono 32bit libs on amd64 yet
+ rm -v lib/libmad.so* lib/libmikmod.so* lib/libopenal.so* || die
+ else
+ rm -v lib/libmad.so* lib/libmikmod.so* lib/libopenal.so* lib/libmono-2.0.so* || die
+ fi
+ fi
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ games_make_wrapper ${PN} "./Solar2.bin.x86" "${MYGAMEDIR}"
+ make_desktop_entry ${PN}
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+
+ fperms +x "${MYGAMEDIR}"/Solar2.bin.x86
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}