summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/super-hexagon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/super-hexagon')
-rw-r--r--games-action/super-hexagon/Manifest1
-rw-r--r--games-action/super-hexagon/metadata.xml11
-rw-r--r--games-action/super-hexagon/super-hexagon-20141027.ebuild85
3 files changed, 97 insertions, 0 deletions
diff --git a/games-action/super-hexagon/Manifest b/games-action/super-hexagon/Manifest
new file mode 100644
index 000000000000..c829ee21d523
--- /dev/null
+++ b/games-action/super-hexagon/Manifest
@@ -0,0 +1 @@
+DIST superhexagon-10272014-bin 29469168 SHA256 f079cd5f644ba69a1123491a3d2bd19069670e6a9884ad756d927be331f3d9c8 SHA512 ec07576e897cddcbb1ef1da104750001b7610ca31d40f41044dc412d8a149fa07b71e9fbc5df8b1d3ad6f110b28e5891dde618e39f4b2565d73fcfae28d3a85a WHIRLPOOL 4c73f6cddce5d4fb6aace87c2b7c660f7e2be9cfcdc37355ba953e83bb06aa3cba554d15e3051ffcbbcc15b0e6473079b811fbf261771a302dfd496e9505057f
diff --git a/games-action/super-hexagon/metadata.xml b/games-action/super-hexagon/metadata.xml
new file mode 100644
index 000000000000..d13413d31d91
--- /dev/null
+++ b/games-action/super-hexagon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
+
diff --git a/games-action/super-hexagon/super-hexagon-20141027.ebuild b/games-action/super-hexagon/super-hexagon-20141027.ebuild
new file mode 100644
index 000000000000..e9a5fd0570ef
--- /dev/null
+++ b/games-action/super-hexagon/super-hexagon-20141027.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# we use bundled glew, cause slotting 1.6 does not give us
+# much benefit for one consumer
+
+EAPI=5
+
+inherit eutils unpacker games
+
+DESCRIPTION="A minimal action game by Terry Cavanagh, with music by Chipzel"
+HOMEPAGE="http://www.superhexagon.com/"
+SRC_URI="superhexagon-${PV:4:4}${PV:0:4}-bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/x86/*
+ ${MYGAMEDIR#/}/x86_64/*"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXxf86vm
+ !bundled-libs? (
+ media-libs/freeglut
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ )"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ einfo "removing ${ARCH} unrelated files"
+ rm -r $(usex amd64 "x86" "x86_64") || die
+
+ if ! use bundled-libs ; then
+ einfo "removing bundled-libs..."
+ cd $(usex amd64 "x86_64" "x86") || die
+ rm libglut.so* libogg.so* libopenal.so* libstdc++.so* \
+ libvorbis.so* libvorbisfile.so*
+ fi
+}
+
+src_install() {
+ local myarch=$(usex amd64 "x86_64" "x86")
+
+ insinto "${MYGAMEDIR}"
+ doins -r data ${myarch} SuperHexagon.png
+
+ dodoc Linux.README
+
+ newicon SuperHexagon.png ${PN}.png
+ make_desktop_entry ${PN}
+ games_make_wrapper ${PN} "./${myarch}/superhexagon.${myarch}" "${MYGAMEDIR}" "${MYGAMEDIR}/${myarch}"
+
+ fperms +x "${MYGAMEDIR}/${myarch}/superhexagon.${myarch}"
+ prepgamesdirs
+}