summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-05-06 20:53:57 +0100
committerJames Le Cuirot <chewi@gentoo.org>2017-05-06 20:53:57 +0100
commit059541e7707feb0d4465a863d2bacbc850d1495f (patch)
tree65d57d8a8412e92b761e073e193876ac7110a5ef /games-action/teeworlds/teeworlds-0.6.3.ebuild
parentapp-emulation/libvirt: drop old versions <2.5.0 (diff)
downloadgentoo-059541e7707feb0d4465a863d2bacbc850d1495f.tar.gz
gentoo-059541e7707feb0d4465a863d2bacbc850d1495f.tar.bz2
gentoo-059541e7707feb0d4465a863d2bacbc850d1495f.zip
games-action/teeworlds: Remove vulnerable 0.6.3 wrt bug #600178
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'games-action/teeworlds/teeworlds-0.6.3.ebuild')
-rw-r--r--games-action/teeworlds/teeworlds-0.6.3.ebuild118
1 files changed, 0 insertions, 118 deletions
diff --git a/games-action/teeworlds/teeworlds-0.6.3.ebuild b/games-action/teeworlds/teeworlds-0.6.3.ebuild
deleted file mode 100644
index 791c9d00e077..000000000000
--- a/games-action/teeworlds/teeworlds-0.6.3.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-inherit eutils multiprocessing python-any-r1 toolchain-funcs games versionator
-
-REVISION="b177-r50edfd37"
-
-DESCRIPTION="Online multi-player platform 2D shooter"
-HOMEPAGE="http://www.teeworlds.com/"
-SRC_URI="https://downloads.teeworlds.com/${P}-src.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug dedicated"
-
-RDEPEND="
- !dedicated? ( media-libs/pnglite
- media-libs/libsdl[X,sound,opengl,video]
- media-sound/wavpack
- virtual/opengl
- app-arch/bzip2
- media-libs/freetype
- virtual/glu
- x11-libs/libX11 )
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- ~dev-util/bam-0.4.0"
-
-S=${WORKDIR}/${P}-src
-MY_PV=$(get_version_component_range 1-2)
-
-pkg_setup() {
- python-any-r1_pkg_setup
- games_pkg_setup
-}
-
-src_prepare() {
- rm -r src/engine/external/* || die
-
- # 01 & 02 from pull request: https://github.com/oy/teeworlds/pull/493
- EPATCH_SOURCE="${FILESDIR}/${MY_PV}" EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
- epatch
-
- cat <<- __EOF__ > "${S}/gentoo.lua"
- function addSettings(settings)
- print("Adding Gentoo settings")
- settings.optimize = 0
- settings.cc.exe_c = "$(tc-getCC)"
- settings.cc.exe_cxx = "$(tc-getCXX)"
- settings.cc.flags_c:Add("${CFLAGS}")
- settings.cc.flags_cxx:Add("${CXXFLAGS}")
- settings.link.exe = "$(tc-getCXX)"
- settings.link.flags:Add("${LDFLAGS}")
- end
- __EOF__
-
- sed -i \
- -e "s#/usr/share/games/teeworlds/data#${GAMES_DATADIR}/${PN}/data#" \
- src/engine/shared/storage.cpp || die
-}
-
-src_configure() {
- bam -v config || die
-}
-
-src_compile() {
- local myopt
-
- if use debug; then
- myopt=" server_debug"
- else
- myopt=" server_release"
- fi
- if ! use dedicated; then
- if use debug; then
- myopt+=" client_debug"
- else
- myopt+=" client_release"
- fi
- fi
-
- bam -v -a -j $(makeopts_jobs) ${myopt} || die
-}
-
-src_install() {
- if use debug; then
- newgamesbin ${PN}_srv_d ${PN}_srv
- else
- dogamesbin ${PN}_srv
- fi
- if ! use dedicated; then
- if use debug; then
- newgamesbin ${PN}_d ${PN}
- else
- dogamesbin ${PN}
- fi
-
- doicon "${FILESDIR}"/${PN}.xpm
- make_desktop_entry ${PN} Teeworlds
-
- insinto "${GAMES_DATADIR}"/${PN}/data
- doins -r data/*
- else
- insinto "${GAMES_DATADIR}"/${PN}/data/maps
- doins -r data/maps/*
- fi
- newinitd "${FILESDIR}"/${PN}-init.d ${PN}
- insinto "/etc/${PN}"
- doins "${FILESDIR}"/teeworlds_srv.cfg
-
- dodoc readme.txt
-
- prepgamesdirs
-}