summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild')
-rw-r--r--games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
new file mode 100644
index 000000000000..8e8e5c964b63
--- /dev/null
+++ b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Tow Bowl Tactics is a game based on Games Workshop's Blood Bowl"
+HOMEPAGE="http://www.towbowltactics.com/index_en.html"
+SRC_URI="http://www.towbowltactics.com/download/tbt.${PV}.src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ media-libs/smpeg
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-net
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/tbt/src
+
+src_prepare() {
+ cd ..
+ edos2unix $(find src -type f) config.xml
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" \
+ src/Makefile || die
+ sed -i \
+ -e "/tbt.ico/ s:\"\./:TBTHOME \"/:" \
+ src/Main.cpp || die
+ sed -i \
+ -e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
+ src/global.h || die
+}
+
+src_install() {
+ dogamesbin tbt
+ dodir "${GAMES_DATADIR}/tbt"
+ cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die
+ insinto "${GAMES_SYSCONFDIR}/tbt"
+ doins ../config.xml
+ newicon ../data/images/panel/turn.png ${PN}.png
+ make_desktop_entry tbt "Tow Bowl Tactics"
+ prepgamesdirs
+}