summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-25 17:30:42 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-03-25 17:33:07 +0100
commitec3bd08eda216b433e9757ef6fdd119fcf1c35a3 (patch)
tree8b2e60ac01bd0ce8476311701a9adf85e1bb905f /games-action/trine-enchanted-edition
parentprofiles: Mask trine-enchanted-edition in non-multilib/glibc profiles (diff)
downloadgentoo-ec3bd08eda216b433e9757ef6fdd119fcf1c35a3.tar.gz
gentoo-ec3bd08eda216b433e9757ef6fdd119fcf1c35a3.tar.bz2
gentoo-ec3bd08eda216b433e9757ef6fdd119fcf1c35a3.zip
games-action/trine-enchanted-edition: New package
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'games-action/trine-enchanted-edition')
-rw-r--r--games-action/trine-enchanted-edition/Manifest1
-rw-r--r--games-action/trine-enchanted-edition/metadata.xml11
-rw-r--r--games-action/trine-enchanted-edition/trine-enchanted-edition-2.12.508.ebuild85
3 files changed, 97 insertions, 0 deletions
diff --git a/games-action/trine-enchanted-edition/Manifest b/games-action/trine-enchanted-edition/Manifest
new file mode 100644
index 000000000000..5c5f1cb6ae9d
--- /dev/null
+++ b/games-action/trine-enchanted-edition/Manifest
@@ -0,0 +1 @@
+DIST trine_enchanted_edition_v2_12_build_508_humble_linux_full.zip 1226749814 BLAKE2B 9803f78279bcf83a2a54f25e2498664b73ba1c0ae5c540bb4479345ae05495cc11527937876fb7c9dbb34d05dbbdb4575cc6c1899923c782ff67ea23bd2cfac9 SHA512 e883763efe89f09a84c2896bfd0a9a13319dd14bb840e67f1812a0bab45bcab7a144f4c9399194e5aabad0435e350c6a903a542c9101a37c602855ebd0884d9d
diff --git a/games-action/trine-enchanted-edition/metadata.xml b/games-action/trine-enchanted-edition/metadata.xml
new file mode 100644
index 000000000000..b26a6baa4124
--- /dev/null
+++ b/games-action/trine-enchanted-edition/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="launcher">Install GTK+ launcher</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-action/trine-enchanted-edition/trine-enchanted-edition-2.12.508.ebuild b/games-action/trine-enchanted-edition/trine-enchanted-edition-2.12.508.ebuild
new file mode 100644
index 000000000000..87871dfbf505
--- /dev/null
+++ b/games-action/trine-enchanted-edition/trine-enchanted-edition-2.12.508.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils gnome2-utils
+
+MY_P="${PV//./_}"
+MY_P="${PN//-/_}_v${MY_P%_*}_build_${MY_P##*_}"
+MY_PN="Trine Enchanted Edition"
+
+DESCRIPTION="The original sidescrolling action platformer under the Trine 2 engine"
+HOMEPAGE="https://www.frozenbyte.com/games/trine-enchanted-edition"
+SRC_URI="${MY_P}_humble_linux_full.zip"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+launcher"
+RESTRICT="bindist fetch splitdebug"
+
+QA_PREBUILT="opt/${PN}/${PN}*"
+
+DEPEND="app-arch/unzip"
+
+# SDL 1.3 is bundled but the game appears to be statically linked
+# against SDL 2.0.3. This is unfortunate as there are bugs. For example,
+# it doesn't respect the DISPLAY variable under Zaphod mode.
+
+RDEPEND="
+ media-gfx/nvidia-cg-toolkit[abi_x86_32]
+ media-libs/alsa-lib[abi_x86_32]
+ media-libs/freetype:2[abi_x86_32]
+ media-libs/libogg[abi_x86_32]
+ >=media-libs/libvorbis-1.3[abi_x86_32]
+ >=media-libs/openal-1.15[abi_x86_32]
+ sys-libs/zlib[abi_x86_32]
+ virtual/glu[abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ launcher? (
+ dev-libs/glib:2[abi_x86_32]
+ media-libs/libpng:1.2[abi_x86_32]
+ x11-libs/gdk-pixbuf:2[abi_x86_32,X]
+ x11-libs/gtk+:2[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/pango[abi_x86_32,X]
+ )"
+
+S="${WORKDIR}/linux/_enchanted_edition_"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ insinto "${dir}"
+ doins -r *.fbq data
+
+ exeinto "${dir}"
+ newexe bin/trine1_linux_32bit ${PN}
+
+ make_wrapper ${PN} ./${PN} "${dir}"
+ make_desktop_entry ${PN} "${MY_PN}"
+
+ if use launcher ; then
+ exeinto "${dir}"
+ newexe bin/trine1_linux_launcher_32bit ${PN}-launcher
+
+ make_wrapper ${PN}-launcher ./${PN}-launcher "${dir}"
+ make_desktop_entry ${PN}-launcher "${MY_PN} (launcher)"
+
+ # Launcher binary has hardcoded the game path.
+ dosym ../${PN} "${dir}"/bin/trine1_bin_starter.sh
+ fi
+
+ newicon -s 64 trine1.png ${PN}.png
+ dodoc readme_changelog.txt
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }