summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/violetland/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/violetland/files')
-rw-r--r--games-action/violetland/files/violetland-0.4.3-boost150.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-action/violetland/files/violetland-0.4.3-boost150.patch b/games-action/violetland/files/violetland-0.4.3-boost150.patch
new file mode 100644
index 000000000000..4e700ca9e3d4
--- /dev/null
+++ b/games-action/violetland/files/violetland-0.4.3-boost150.patch
@@ -0,0 +1,41 @@
+--- CMakeLists.txt.old 2012-11-05 15:19:11.501044743 +0100
++++ CMakeLists.txt 2012-11-05 15:19:25.415250207 +0100
+@@ -8,7 +8,6 @@
+ find_package(SDL_mixer REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(Boost COMPONENTS filesystem system REQUIRED)
+-add_definitions(-DBOOST_FILESYSTEM_VERSION=2)
+
+ if(${MINGW})
+ set(INTL_LIBRARY intl)
+--- src/system/utility/FileUtility.cpp.old 2012-11-05 21:26:07.865488297 +0100
++++ src/system/utility/FileUtility.cpp 2012-11-05 21:30:44.881208230 +0100
+@@ -20,7 +20,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_regular_file(*dir_it))
+- files.push_back(dir_it->filename());
++ files.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return files;
+@@ -32,8 +32,8 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
+- subDirs.push_back(dir_it->path().filename());
++ if (dir_it->path().filename().string()[0] != '.')
++ subDirs.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return subDirs;
+@@ -45,7 +45,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
++ if (dir_it->path().filename().string()[0] != '.')
+ ++count;
+ ++dir_it;
+ }