summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/xblast/xblast-2.10.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/xblast/xblast-2.10.4.ebuild')
-rw-r--r--games-action/xblast/xblast-2.10.4.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-action/xblast/xblast-2.10.4.ebuild b/games-action/xblast/xblast-2.10.4.ebuild
new file mode 100644
index 000000000000..bf8cfbc82f02
--- /dev/null
+++ b/games-action/xblast/xblast-2.10.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools games
+
+# Change these as releases changes
+IMAGES="images-2005-01-06"
+LEVELS="levels-2005-01-06"
+MODELS="models-2005-01-06"
+MUSICS="musics-2005-01-06"
+SOUNDS="sounds"
+
+DESCRIPTION="Bomberman clone w/network support for up to 6 players"
+HOMEPAGE="http://xblast.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xblast/${P}.tar.gz
+ mirror://sourceforge/xblast/${IMAGES}.tar.gz
+ mirror://sourceforge/xblast/${LEVELS}.tar.gz
+ mirror://sourceforge/xblast/${MODELS}.tar.gz
+ mirror://sourceforge/xblast/${MUSICS}.tar.gz
+ mirror://sourceforge/xblast/${SOUNDS}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libX11
+ media-libs/libpng"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+src_prepare() {
+ eautoreconf #255857
+}
+
+src_configure() {
+ egamesconf \
+ --with-otherdatadir="${GAMES_DATADIR}"/${PN} \
+ --enable-sound
+}
+
+src_install() {
+ local IMAGE_INSTALL_DIR="${GAMES_DATADIR}/${PN}/image"
+
+ default
+
+ # Images
+ dodir "${IMAGE_INSTALL_DIR}"
+ cp -pPR "${WORKDIR}/${IMAGES}"/* "${D}/${IMAGE_INSTALL_DIR}" \
+ || die "cp failed"
+
+ # Levels
+ insinto "${GAMES_DATADIR}/xblast/level"
+ doins "${WORKDIR}/${LEVELS}"/*
+
+ # Models
+ insinto "${GAMES_DATADIR}/xblast/image/sprite"
+ doins "${WORKDIR}/${MODELS}"/*
+
+ # Music and sound
+ insinto "${GAMES_DATADIR}/xblast/sounds"
+ doins "${WORKDIR}/${MUSICS}"/* "${WORKDIR}/${SOUNDS}"/*
+
+ # Cleanup
+ find "${D}" -name Imakefile -exec rm \{\} \;
+
+ prepgamesdirs
+}