summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 10:05:48 +0100
committerSam James <sam@gentoo.org>2021-04-21 19:50:02 +0100
commit5085200979d9602e1931d82f87bb75a1edab45cd (patch)
tree608ae99f55b1a3b09ff0ff5c09c5ad81d02ad431 /games-action/xbomber
parentgames-rpg/comi: replace eutils with desktop, wrapper (diff)
downloadgentoo-5085200979d9602e1931d82f87bb75a1edab45cd.tar.gz
gentoo-5085200979d9602e1931d82f87bb75a1edab45cd.tar.bz2
gentoo-5085200979d9602e1931d82f87bb75a1edab45cd.zip
games-action/xbomber: update EAPI 6 -> 7, respect CC
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action/xbomber')
-rw-r--r--games-action/xbomber/xbomber-101-r1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/games-action/xbomber/xbomber-101-r1.ebuild b/games-action/xbomber/xbomber-101-r1.ebuild
index 2757b322f5db..c6c7c8ab4069 100644
--- a/games-action/xbomber/xbomber-101-r1.ebuild
+++ b/games-action/xbomber/xbomber-101-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Bomberman clone w/multiplayer support"
HOMEPAGE="http://www.xdr.com/dash/bomber.html"
@@ -10,7 +12,6 @@ SRC_URI="http://www.xdr.com/dash/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="x11-libs/libX11"
RDEPEND="!sci-biology/emboss
@@ -39,9 +40,17 @@ src_prepare() {
-e "s:=\"data\":=\"/usr/share/${PN}\":" sound.c || die
}
+src_compile() {
+ tc-export CC
+
+ emake
+}
+
src_install() {
dobin matcher bomber
+
insinto /usr/share/${PN}
doins -r data/*
+
dodoc README Changelog
}