summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2015-09-17 22:16:38 +0200
committerTupone Alfredo <tupone@gentoo.org>2015-09-18 18:51:54 +0200
commit0cbcd2f9038934d09fe6728be64695083eb679f1 (patch)
treed469f7ba70b049a7b2ca25001e00158d5e46cdb9 /games-action
parentapp-crypt/pinentry: Fix Qt4 support (diff)
downloadgentoo-0cbcd2f9038934d09fe6728be64695083eb679f1.tar.gz
gentoo-0cbcd2f9038934d09fe6728be64695083eb679f1.tar.bz2
gentoo-0cbcd2f9038934d09fe6728be64695083eb679f1.zip
games-action/bomberclone: Build with gcc:5.2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bomberclone/bomberclone-0.11.8.ebuild5
-rw-r--r--games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch11
2 files changed, 14 insertions, 2 deletions
diff --git a/games-action/bomberclone/bomberclone-0.11.8.ebuild b/games-action/bomberclone/bomberclone-0.11.8.ebuild
index 155c9d2cb052..82e306259943 100644
--- a/games-action/bomberclone/bomberclone-0.11.8.ebuild
+++ b/games-action/bomberclone/bomberclone-0.11.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,7 +22,8 @@ RDEPEND="${DEPEND}"
src_prepare() {
ecvs_clean
- epatch "${FILESDIR}"/${P}-underlink.patch
+ epatch "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc52.patch
eautoreconf
}
diff --git a/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch b/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch
new file mode 100644
index 000000000000..51fdaee52c5f
--- /dev/null
+++ b/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch
@@ -0,0 +1,11 @@
+--- src/single.c.old 2015-09-17 09:21:57.826930680 +0200
++++ src/single.c 2015-09-17 09:22:04.315824372 +0200
+@@ -476,7 +476,7 @@
+ };
+
+
+-inline int
++static inline int
+ ai_checknewpos (_point pos, int d)
+ {
+ _point m;