summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-07-23 11:08:41 -0300
committerSam James <sam@gentoo.org>2022-07-29 04:15:02 +0100
commit5d63961c59578a8886e3deb7d4c8882dbde44ec2 (patch)
treeea108217c7dc72377fcd79211796e54c2427a432 /games-action
parentgames-action/polymc: explicitly add Qt5 build config (diff)
downloadgentoo-5d63961c59578a8886e3deb7d4c8882dbde44ec2.tar.gz
gentoo-5d63961c59578a8886e3deb7d4c8882dbde44ec2.tar.bz2
gentoo-5d63961c59578a8886e3deb7d4c8882dbde44ec2.zip
games-action/polymc: add 1.4.0
Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/polymc/Manifest1
-rw-r--r--games-action/polymc/polymc-1.4.0.ebuild125
2 files changed, 126 insertions, 0 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
index 18eb23870758..0edfec45ad29 100644
--- a/games-action/polymc/Manifest
+++ b/games-action/polymc/Manifest
@@ -1 +1,2 @@
DIST polymc-1.3.2.tar.gz 5641952 BLAKE2B f1014c79c394db79e07bcd55c65c930ace80274a83cffc4c8adff58547f3ddf9baa5685ecd7b860c8ec21e4ae4ebf407233d3cb2b8d9ae2a81abd31248b1cebf SHA512 f272248631e76e2cb3b74f3bc91ab3d4f7e7cf4fb7396a09b8bcaf65d928076f49e436e3d7c1a34c32a2cbcf10760709f86cd9c0eca285b66790f25b1c466ea0
+DIST polymc-1.4.0.tar.gz 5766980 BLAKE2B 2588f9bade8dcd1e6bc4a9eb8a496448562a05428121e5547e5f66213b178e906b557b4636d30125aaa203e2cb00c6dfcc351f8bf038d352693adfb5811112d6 SHA512 5492310bb382a08bfef01843e476839723c33734cca46f850f08538f5b2c2d421d40fcb57bc207d36e08337230e5f29a594f33bd354d3a9bee5c801a1cd77fe0
diff --git a/games-action/polymc/polymc-1.4.0.ebuild b/games-action/polymc/polymc-1.4.0.ebuild
new file mode 100644
index 000000000000..79439b22ba10
--- /dev/null
+++ b/games-action/polymc/polymc-1.4.0.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PolyMC/PolyMC
+ https://github.com/PolyMC/libnbtplusplus
+ "
+
+ EGIT_SUBMODULES=( 'depends/libnbtplusplus' )
+else
+ MY_PN="PolyMC"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# GPL-3 for PolyMC
+# LGPL-3 for libnbtplusplus
+# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
+LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
+
+SLOT="0"
+
+IUSE="debug lto test"
+REQUIRED_USE="
+ lto? ( !debug )
+"
+
+RESTRICT="!test? ( test )"
+
+MIN_QT="5.12.0"
+
+QT_DEPS="
+ >=dev-qt/qtconcurrent-${MIN_QT}:5
+ >=dev-qt/qtcore-${MIN_QT}:5
+ >=dev-qt/qtgui-${MIN_QT}:5
+ >=dev-qt/qtnetwork-${MIN_QT}:5
+ >=dev-qt/qttest-${MIN_QT}:5
+ >=dev-qt/qtwidgets-${MIN_QT}:5
+ >=dev-qt/qtxml-${MIN_QT}:5
+"
+
+# Required at both build-time and run-time
+COMMON_DEPENDS="
+ ${QT_DEPS}
+ >=dev-libs/quazip-1.3:=
+ sys-libs/zlib
+"
+
+DEPEND="
+ ${COMMON_DEPENDS}
+ app-text/scdoc
+ kde-frameworks/extra-cmake-modules
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${COMMON_DEPENDS}
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+}
+
+src_configure(){
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named polymc
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ # Force Qt5 to avoid accidentaly building the Qt6 version and breaking things
+ -DLauncher_QT_VERSION_MAJOR=5
+
+ -DENABLE_LTO=$(usex lto)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
+
+ optfeature "built-in MangoHud support" games-util/mangohud
+ optfeature "built-in Feral Gamemode support" games-util/gamemode
+}