summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-15 22:22:50 +0000
committerSam James <sam@gentoo.org>2022-11-15 22:23:52 +0000
commit8b554583afbc464866b8a17d66b2a19906d671ae (patch)
treefc5f6d0ecaa2ccfd98f13b21525a9e1b2369039a /games-action
parentapp-emulation/wine-staging: update live (diff)
downloadgentoo-8b554583afbc464866b8a17d66b2a19906d671ae.tar.gz
gentoo-8b554583afbc464866b8a17d66b2a19906d671ae.tar.bz2
gentoo-8b554583afbc464866b8a17d66b2a19906d671ae.zip
Revert "games-action/prismlauncher: add 5.2"
This reverts commit 738e102233faf498e1d3c06db700b92969804319. Wrong Signed-off-by / git author. Innocent mistake but let's revert for accuracy. PGP signature is from andrewammerlaan@gentoo.org so nothing nefarious going on. Bug: https://github.com/gentoo/gentoo/pull/28288 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/prismlauncher/Manifest1
-rw-r--r--games-action/prismlauncher/prismlauncher-5.2.ebuild147
2 files changed, 0 insertions, 148 deletions
diff --git a/games-action/prismlauncher/Manifest b/games-action/prismlauncher/Manifest
index a67273d1d76f..3521bda3e2dc 100644
--- a/games-action/prismlauncher/Manifest
+++ b/games-action/prismlauncher/Manifest
@@ -1,2 +1 @@
DIST prismlauncher-5.1.tar.gz 9401315 BLAKE2B 22a0508efc042a78099d0458d305c623465533d9770b111e584f4591cbd9372b354501fb3edf941f4c9f744f3540bd793c00f1ca428705bd2ca140be87056575 SHA512 2e0de23040b26c3bf9d3758b3c8ee0db6516edab9d25d64beca6ddde4c039d88655349895a1ab15b63c8c2e26f3fedbf2ef9f9c14ce5a86149aa75374c24cd5f
-DIST prismlauncher-5.2.tar.gz 8772931 BLAKE2B 95c5be2a177086ba15a1d14a85f8a0edb349bcfbe4e9adff9dcca5c4a8dbf00d3ec49e30a2c99cfbeca2a7617ccaba6cf1f86bd396c1bf9b306c0ad5c1f4a3c7 SHA512 96a5fbf7c5d80da72377a4d8e9df16d4f9597a5764386f5b60d520d84fe319f8b6fbb3f89715214a037a70c440e418eb72e933a911d253fad93fbda9213d16e5
diff --git a/games-action/prismlauncher/prismlauncher-5.2.ebuild b/games-action/prismlauncher/prismlauncher-5.2.ebuild
deleted file mode 100644
index ad60b690649f..000000000000
--- a/games-action/prismlauncher/prismlauncher-5.2.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake java-pkg-2 optfeature xdg
-
-HOMEPAGE="https://prismlauncher.org/ https://github.com/PrismLauncher/PrismLauncher"
-DESCRIPTION="A custom, open source Minecraft launcher"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="
- https://github.com/PrismLauncher/PrismLauncher
- "
-
- # TODO: Add tomlplusplus as a system library, like quazip
- EGIT_SUBMODULES=( '*' '-libraries/quazip' '-libraries/filesystem' )
-else
- MY_PN="PrismLauncher"
-
- # Let's use the vendored tarball to avoid dealing with the submodules directly
- SRC_URI="
- https://github.com/PrismLauncher/PrismLauncher/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
- "
-
- # The Prism's files are unpacked to ${WORKDIR}/PrismLauncher-${PV}
- S="${WORKDIR}/${MY_PN}-${PV}"
-
- KEYWORDS="~amd64 ~arm64"
-fi
-
-# GPL-3 for PolyMC (PrismLauncher is forked from it) and Prism itself
-# Apache-2.0 for MultiMC (PolyMC is forked from it)
-# LGPL-3+ for libnbtplusplus
-# MIT for tomlplusplus
-# See the rest of PrismLauncher's libraries at https://github.com/PrismLauncher/PrismLauncher/tree/develop/libraries
-LICENSE="Apache-2.0 BSD BSD-2 GPL-2+ GPL-3 ISC LGPL-2.1+ LGPL-3+ MIT"
-
-SLOT="0"
-
-IUSE="debug lto qt6 test"
-REQUIRED_USE="
- lto? ( !debug )
-"
-
-RESTRICT="!test? ( test )"
-
-MIN_QT_5_VERSION="5.12.0"
-MIN_QT_6_VERSION="6.0.0"
-
-QT_DEPS="
- !qt6? (
- >=dev-qt/qtconcurrent-${MIN_QT_5_VERSION}:5
- >=dev-qt/qtcore-${MIN_QT_5_VERSION}:5
- >=dev-qt/qtgui-${MIN_QT_5_VERSION}:5
- >=dev-qt/qtnetwork-${MIN_QT_5_VERSION}:5
- >=dev-qt/qttest-${MIN_QT_5_VERSION}:5
- >=dev-qt/qtwidgets-${MIN_QT_5_VERSION}:5
- >=dev-qt/qtxml-${MIN_QT_5_VERSION}:5
- )
-
- qt6? (
- >=dev-qt/qtbase-${MIN_QT_6_VERSION}:6[concurrent,gui,network,widgets,xml(+)]
- >=dev-qt/qt5compat-${MIN_QT_6_VERSION}:6
- )
-"
-
-# Required at both build-time and run-time
-COMMON_DEPENDS="
- ${QT_DEPS}
-
- !qt6? ( >=dev-libs/quazip-1.3:=[qt5(+)] )
- qt6? ( >=dev-libs/quazip-1.3:=[qt6(-)] )
-
- sys-libs/zlib
-"
-
-# The gulrak-filesystem dependency is only needed at build time, because we don't actually use it on Linux,
-# only on legacy macOS. Still, we need it present at build time to appease CMake, and having it like this
-# makes it easier to maintain than patching the CMakeLists file directly.
-BDEPEND="
- app-text/scdoc
- dev-cpp/gulrak-filesystem
- kde-frameworks/extra-cmake-modules:5
-"
-
-DEPEND="
- ${COMMON_DEPENDS}
- media-libs/libglvnd
- >=virtual/jdk-1.8.0:*
-"
-
-# At run-time we don't depend on JDK, only JRE
-# And we need more than just the GL headers
-RDEPEND="
- ${COMMON_DEPENDS}
-
- !qt6? ( >=dev-qt/qtsvg-${MIN_QT_5_VERSION}:5 )
- qt6? ( >=dev-qt/qtsvg-${MIN_QT_6_VERSION}:6 )
-
- >=virtual/jre-1.8.0:*
- virtual/opengl
-"
-
-src_prepare() {
- cmake_src_prepare
-
- # Prevent conflicting with the user's flags
- # See https://bugs.gentoo.org/848765 for more info
- sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
-}
-
-src_configure(){
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="/usr"
- # Resulting binary is named prismlauncher
- -DLauncher_APP_BINARY_NAME="${PN}"
- -DLauncher_QT_VERSION_MAJOR=$(usex qt6 6 5)
-
- -DENABLE_LTO=$(usex lto)
- -DBUILD_TESTING=$(usex test)
- )
-
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- CMAKE_BUILD_TYPE=Release
- fi
-
- cmake_src_configure
-}
-
-src_compile(){
- cmake_src_compile
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # Original issue: https://github.com/PolyMC/PolyMC/issues/227
- optfeature "old Minecraft (<= 1.12.2) support" x11-apps/xrandr
-
- optfeature "built-in MangoHud support" games-util/mangohud
- optfeature "built-in Feral Gamemode support" games-util/gamemode
-}