summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-11 19:11:14 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-11 19:21:50 +0200
commite1b400a259946c52aac5ca9971c8df06c8519fb9 (patch)
treefd2fa12bfef77eb58361d07b61445c0b1aa62b7e /games-action
parentnet-dns/pdns-recursor: Cleanup (diff)
downloadgentoo-e1b400a259946c52aac5ca9971c8df06c8519fb9.tar.gz
gentoo-e1b400a259946c52aac5ca9971c8df06c8519fb9.tar.bz2
gentoo-e1b400a259946c52aac5ca9971c8df06c8519fb9.zip
games-action/lugaru: Fix building with media-libs/jpeg
Closes: https://bugs.gentoo.org/652930 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/lugaru/files/lugaru-20151204-jpeg-9c.patch13
-rw-r--r--games-action/lugaru/lugaru-20151204-r1.ebuild5
2 files changed, 16 insertions, 2 deletions
diff --git a/games-action/lugaru/files/lugaru-20151204-jpeg-9c.patch b/games-action/lugaru/files/lugaru-20151204-jpeg-9c.patch
new file mode 100644
index 000000000000..ac0ee48f62d6
--- /dev/null
+++ b/games-action/lugaru/files/lugaru-20151204-jpeg-9c.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/652930
+
+--- a/Source/OpenGL_Windows.cpp
++++ b/Source/OpenGL_Windows.cpp
+@@ -839,7 +839,7 @@
+ (void) jpeg_read_header(&cinfo, TRUE);
+
+ cinfo.out_color_space = JCS_RGB;
+- cinfo.quantize_colors = 0;
++ cinfo.quantize_colors = FALSE;
+ (void) jpeg_calc_output_dimensions(&cinfo);
+ (void) jpeg_start_decompress(&cinfo);
+
diff --git a/games-action/lugaru/lugaru-20151204-r1.ebuild b/games-action/lugaru/lugaru-20151204-r1.ebuild
index 16843cc472c0..9860f427cdd0 100644
--- a/games-action/lugaru/lugaru-20151204-r1.ebuild
+++ b/games-action/lugaru/lugaru-20151204-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,7 +27,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}/${P}-dir.patch"
+ "${FILESDIR}"/${P}-dir.patch
+ "${FILESDIR}"/${P}-jpeg-9c.patch
)
src_prepare() {