summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:12:00 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:08 +0000
commitf569877e8a39f767312842f3789d874fef7024a5 (patch)
treed7aa158eff2a06fcc2e4cd6b262d2b11a704312b /games-action
parentdev-lang/mercury-extras: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-f569877e8a39f767312842f3789d874fef7024a5.tar.gz
gentoo-f569877e8a39f767312842f3789d874fef7024a5.tar.bz2
gentoo-f569877e8a39f767312842f3789d874fef7024a5.zip
games-action/moon-buggy: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild b/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild
index 828120c3cab0..7903607dfc3e 100644
--- a/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild
+++ b/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,7 +30,7 @@ src_prepare() {
src_configure() {
econf \
--sharedstatedir="/var/games" \
- --with-curses-libs="$(pkg-config ncurses --libs)"
+ --with-curses-libs="$($(tc-getPKG_CONFIG) ncurses --libs)"
}
src_install() {