summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/aquaria/aquaria-1.1.3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/aquaria/aquaria-1.1.3-r1.ebuild')
-rw-r--r--games-arcade/aquaria/aquaria-1.1.3-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/aquaria/aquaria-1.1.3-r1.ebuild b/games-arcade/aquaria/aquaria-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..eee55b17b05f
--- /dev/null
+++ b/games-arcade/aquaria/aquaria-1.1.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit unpacker eutils games
+
+DESCRIPTION="A 2D scroller set in a massive ocean world"
+HOMEPAGE="http://www.bit-blot.com/aquaria/"
+SRC_URI="aquaria-lnx-humble-bundle.mojo.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip fetch bindist"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ echo
+ elog "Download ${SRC_URI} from ${HOMEPAGE} and place it in ${DISTDIR}"
+ echo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+
+ doins -r *.xml */
+ doexe "${PN}"
+ doicon "${PN}.png"
+
+ dodoc README-linux.txt
+ mv "${ED}/${dir}"/docs "${ED}/usr/share/doc/${PF}/html" || die
+ dosym /usr/share/doc/${PF}/html "${dir}"/docs
+
+ games_make_wrapper "${PN}" "./${PN}" "${dir}"
+ make_desktop_entry "${PN}" "Aquaria"
+
+ prepgamesdirs
+}