summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 11:10:43 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 11:11:28 +0200
commitd7a7cf3b48b5eb8145bc8163471cba065df748ef (patch)
tree064e93fd191b7ab56aaeadb9cb0bb4b7c966db79 /games-arcade/asteroid/files
parentgames-arcade/ascii-invaders: Drop old (diff)
downloadgentoo-d7a7cf3b48b5eb8145bc8163471cba065df748ef.tar.gz
gentoo-d7a7cf3b48b5eb8145bc8163471cba065df748ef.tar.bz2
gentoo-d7a7cf3b48b5eb8145bc8163471cba065df748ef.zip
games-arcade/asteroid: Version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/asteroid/files')
-rw-r--r--games-arcade/asteroid/files/asteroid-1.2.1-libm.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/games-arcade/asteroid/files/asteroid-1.2.1-libm.patch b/games-arcade/asteroid/files/asteroid-1.2.1-libm.patch
new file mode 100644
index 000000000000..cb6e7aaafe29
--- /dev/null
+++ b/games-arcade/asteroid/files/asteroid-1.2.1-libm.patch
@@ -0,0 +1,24 @@
+From 4efc7fc0a1246f023d6f96b94081678e302ab430 Mon Sep 17 00:00:00 2001
+From: Charles Lindsay <chaz@chazomatic.us>
+Date: Mon, 23 May 2016 18:50:34 -0700
+Subject: [PATCH] Add libm to link command
+
+Without it, some systems (and now mine!) would give a linker error about
+missing libm.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 29fd714..ab9a7ec 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -39,7 +39,7 @@ include_directories("${PROJECT_BINARY_DIR}/include")
+ file(GLOB asteroid_SRCS "src/*.c")
+ add_executable(asteroid ${asteroid_SRCS})
+ include_directories(${OPENGL_INCLUDE_DIR} ${GLUT_INCLUDE_DIR})
+-target_link_libraries(asteroid ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES})
++target_link_libraries(asteroid m ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES})
+ if(Asteroid_BUILD_GTK)
+ include_directories(${GTK2_INCLUDE_DIRS})
+ target_link_libraries(asteroid ${GTK2_LIBRARIES})