summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/bloboats
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/bloboats')
-rw-r--r--games-arcade/bloboats/Manifest1
-rw-r--r--games-arcade/bloboats/bloboats-1.0.2.ebuild47
-rw-r--r--games-arcade/bloboats/files/bloboats-1.0.2-warnings.patch24
-rw-r--r--games-arcade/bloboats/metadata.xml5
4 files changed, 77 insertions, 0 deletions
diff --git a/games-arcade/bloboats/Manifest b/games-arcade/bloboats/Manifest
new file mode 100644
index 000000000000..fd490b075606
--- /dev/null
+++ b/games-arcade/bloboats/Manifest
@@ -0,0 +1 @@
+DIST bloboats-1.0.2.tar.gz 7592902 SHA256 4aa5cbba7bae4471daefc6ba058cf6a84c62a4c06cd104a525f9ea1108787ccd SHA512 456339557270440ed4efc5b5cc217c1d1f967ba8ea630f5d9557afe4f4a6cafed749a38596bec0c5daec60cb87e9e8cf72c3a73c604e7777b804d07ff352f1c2 WHIRLPOOL a137be75f50045d34c66e1f14e10c59d8b1109813fa0a48f14e6232b6c8065be59bbbe8b52cc70b1b5b9b9a5c1745736cad452b386f3cfb64e6a99e0d1be5489
diff --git a/games-arcade/bloboats/bloboats-1.0.2.ebuild b/games-arcade/bloboats/bloboats-1.0.2.ebuild
new file mode 100644
index 000000000000..024b65e42a71
--- /dev/null
+++ b/games-arcade/bloboats/bloboats-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="arcade-like boat racing game combining platform jumpers and elastomania / x-moto like games"
+HOMEPAGE="http://bloboats.dy.fi/"
+SRC_URI="http://mirror.kapsi.fi/bloboats.dy.fi/${P}.tar.gz"
+
+LICENSE="GPL-2 CC-Sampling-Plus-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[opengl,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ virtual/opengl
+ virtual/glu
+ media-libs/libvorbis"
+REDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch
+ sed -i \
+ -e "/PREFIX/s://:${D}:" \
+ -e "/DATADIR/s:/usr/games/bloboats/data:${GAMES_DATADIR}/${PN}:" \
+ -e "/BINARYDIR/s:/usr/bin:${GAMES_BINDIR}:" \
+ -e "/CONFIGDIR/s:/etc:${GAMES_SYSCONFDIR}:" \
+ -e "/CXXFLAGS_DEFAULT/s:-O2:${CXXFLAGS} \$(LDFLAGS):" \
+ -e "/^CXX[ _]/d" \
+ -e '/STRIP/d' \
+ Makefile || die
+}
+
+src_install() {
+ dogamesbin bin/bloboats
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ insinto "$GAMES_SYSCONFDIR"
+ doins bloboats.dirs
+ dodoc readme.txt
+ prepgamesdirs
+}
diff --git a/games-arcade/bloboats/files/bloboats-1.0.2-warnings.patch b/games-arcade/bloboats/files/bloboats-1.0.2-warnings.patch
new file mode 100644
index 000000000000..d05f2dd9bdc1
--- /dev/null
+++ b/games-arcade/bloboats/files/bloboats-1.0.2-warnings.patch
@@ -0,0 +1,24 @@
+diff -ru bloboats-1.0.2.orig/src/menu.cpp bloboats-1.0.2/src/menu.cpp
+--- bloboats-1.0.2.orig/src/menu.cpp 2010-08-25 17:55:26.000000000 -0400
++++ bloboats-1.0.2/src/menu.cpp 2010-11-28 01:19:57.664406227 -0500
+@@ -118,7 +118,7 @@
+ bool used=false;
+
+ if (fgets(nick, NICK_MAXLEN+2, fp)) {
+- if (nick && strlen(nick)>1 ) {
++ if (strlen(nick)>1 ) {
+ nick[strlen(nick)-1]='\0';
+ used=true;
+ Player[i].setnick(nick);
+diff -ru bloboats-1.0.2.orig/src/path.cpp bloboats-1.0.2/src/path.cpp
+--- bloboats-1.0.2.orig/src/path.cpp 2006-08-02 18:05:36.000000000 -0400
++++ bloboats-1.0.2/src/path.cpp 2010-11-28 01:19:19.385415683 -0500
+@@ -111,7 +111,7 @@
+ }
+
+ if (type>0) {
+- if (d2) {
++ if (*d2) {
+ char *ps = new char[p.size()+1];
+ strncpy (ps, p.c_str(), p.size()+1);
+
diff --git a/games-arcade/bloboats/metadata.xml b/games-arcade/bloboats/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/bloboats/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>