summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/briquolo/briquolo-0.5.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/briquolo/briquolo-0.5.7.ebuild')
-rw-r--r--games-arcade/briquolo/briquolo-0.5.7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-arcade/briquolo/briquolo-0.5.7.ebuild b/games-arcade/briquolo/briquolo-0.5.7.ebuild
new file mode 100644
index 000000000000..2690ebcf66e1
--- /dev/null
+++ b/games-arcade/briquolo/briquolo-0.5.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Breakout with 3D representation based on OpenGL"
+HOMEPAGE="http://briquolo.free.fr/en/index.html"
+SRC_URI="http://briquolo.free.fr/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/libpng
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+ # no thanks we'll take care of it.
+ sed -i \
+ -e '/^SUBDIRS/s/desktop//' \
+ Makefile.in \
+ || die "sed Makefile.in failed"
+ sed -i \
+ -e "/CXXFLAGS/s:-O3:${CXXFLAGS}:" \
+ -e 's:=.*share/locale:=/usr/share/locale:' \
+ configure \
+ || die "sed configure failed"
+ sed -i \
+ -e 's:$(datadir)/locale:/usr/share/locale:' \
+ po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ doicon desktop/briquolo.svg
+ make_desktop_entry briquolo Briquolo
+ prepgamesdirs
+}