summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/cdogs-sdl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/cdogs-sdl')
-rw-r--r--games-arcade/cdogs-sdl/Manifest2
-rw-r--r--games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild58
-rw-r--r--games-arcade/cdogs-sdl/files/cdogs-sdl-0.4-64bit.patch48
-rw-r--r--games-arcade/cdogs-sdl/metadata.xml11
4 files changed, 119 insertions, 0 deletions
diff --git a/games-arcade/cdogs-sdl/Manifest b/games-arcade/cdogs-sdl/Manifest
new file mode 100644
index 000000000000..bf9fbba53866
--- /dev/null
+++ b/games-arcade/cdogs-sdl/Manifest
@@ -0,0 +1,2 @@
+DIST cdogs-data-2007-07-06.tar.bz2 218810 SHA256 6c5a10dee1a131f353853223fddf9208c0695f076d4e18a22e9f82800a94ebdc SHA512 9e645d64bcc0b99df9fb113f7103590eb8045ca9439700279c8ea55a6277d10fc38aff38bb1137887bc5697c505fe18e15d6c62eaf2790c065b1261fa7418a84 WHIRLPOOL aa5be5e797849ffeae01990462c8793bfd01b49685e2279239400904b9edb96759dbd4b33ee5759b99bdb9b2fdc76a2607d0cb9a34fe972ceb0fc6e669937865
+DIST cdogs-sdl-0.4.tar.bz2 164804 SHA256 63b7cabf6040c939735b4776e3f0fa90df711ee5a94b2387afca2d07b9876fd6 SHA512 69fbac533207e38c85cf0f71db47df50405a5ff220a6662f7e186d1f54c4181ee56e1ff8049a427acec7fcf0529b8df66db36a693978bb0aa04eb0594a8b5adc WHIRLPOOL 3d615585ee3d3cc8296d68fee91c160c70e891eebbee6a951a04f8a6e049d056bc312975977a51efe6e4d5bf15010eb9c60d269747f93b3143137405ef14338f
diff --git a/games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild b/games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild
new file mode 100644
index 000000000000..ec3c7898a736
--- /dev/null
+++ b/games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+CDOGS_DATA="cdogs-data-2007-07-06"
+DESCRIPTION="A port of the old DOS arcade game C-Dogs"
+HOMEPAGE="http://lumaki.com/code/cdogs"
+SRC_URI="http://icculus.org/cdogs-sdl/files/src/${P}.tar.bz2
+ http://icculus.org/cdogs-sdl/files/data/${CDOGS_DATA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ mv ${CDOGS_DATA} ${P}/data || die "Failed moving data around"
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^CF_OPT/d" \
+ -e "/^CC/d" \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "/\bopen(/s/)/, 0666)/" \
+ files.c \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-64bit.patch
+}
+
+src_compile() {
+ emake I_AM_CONFIGURED=yes \
+ SYSTEM="\"linux\"" \
+ STRIP=true \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ cdogs
+}
+
+src_install() {
+ dogamesbin cdogs
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ../data/*
+ newicon ../data/cdogs_icon.png ${PN}.png
+ dodoc ../doc/{README,AUTHORS,ChangeLog,README_DATA,TODO,original_readme.txt}
+ make_desktop_entry "cdogs -fullscreen" C-Dogs
+ prepgamesdirs
+}
diff --git a/games-arcade/cdogs-sdl/files/cdogs-sdl-0.4-64bit.patch b/games-arcade/cdogs-sdl/files/cdogs-sdl-0.4-64bit.patch
new file mode 100644
index 000000000000..bcab13c0ebfd
--- /dev/null
+++ b/games-arcade/cdogs-sdl/files/cdogs-sdl-0.4-64bit.patch
@@ -0,0 +1,48 @@
+--- src/grafx.c
++++ src/grafx.c
+@@ -216,12 +216,6 @@
+ SDL_VideoQuit();
+ }
+
+-typedef struct _Pic {
+- short int w;
+- short int h;
+- char *data;
+-} Pic;
+-
+ int ReadPics(const char *filename, void **pics, int maxPics,
+ color * palette)
+ {
+@@ -241,12 +235,12 @@
+ fread(&size, sizeof(size), 1, f);
+ swap16(&size);
+ if (size) {
+- Pic *p = sys_mem_alloc(size);
++ unsigned char *p = sys_mem_alloc(size);
+
+- f_read16(f, &p->w, 2);
+- f_read16(f, &p->h, 2);
++ f_read16(f, &p[0], 2); // w
++ f_read16(f, &p[2], 2); // h
+
+- f_read(f, &p->data, size - 4);
++ f_read(f, &p[4], size - 4); // data
+
+ pics[i] = p;
+
+@@ -278,11 +272,11 @@
+ fread(&size, sizeof(size), 1, f);
+ swap16(&size);
+ if (size) {
+- Pic *p = sys_mem_alloc(size);
++ unsigned char *p = sys_mem_alloc(size);
+
+- f_read16(f, &p->w, 2);
+- f_read16(f, &p->h, 2);
+- f_read(f, &p->data, size - 4);
++ f_read16(f, &p[0], 2); // w
++ f_read16(f, &p[2], 2); // h
++ f_read(f, &p[4], size - 4); // data
+
+ pics[i] = p;
+
diff --git a/games-arcade/cdogs-sdl/metadata.xml b/games-arcade/cdogs-sdl/metadata.xml
new file mode 100644
index 000000000000..0999c6a1d83a
--- /dev/null
+++ b/games-arcade/cdogs-sdl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+C-Dogs is an arcade shoot-em-up which lets players work alone and
+cooperatively during missions or fight against each other in the "dogfight"
+deathmatch mode. The DOS version of C-Dogs came with severla built in missions
+and dogfight maps. This version does too.
+</longdescription>
+</pkgmetadata>