summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 20:39:05 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 21:00:24 +0200
commitc5093972efdb58f6c0ed45c9d984edfc321291cc (patch)
tree0f3297e62d919013536f89e2c34edcabbd63af80 /games-arcade/cosmosmash/cosmosmash-1.4.7-r1.ebuild
parentgames-arcade/conveysdl: Drop old (diff)
downloadgentoo-c5093972efdb58f6c0ed45c9d984edfc321291cc.tar.gz
gentoo-c5093972efdb58f6c0ed45c9d984edfc321291cc.tar.bz2
gentoo-c5093972efdb58f6c0ed45c9d984edfc321291cc.zip
games-arcade/cosmosmash: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/cosmosmash/cosmosmash-1.4.7-r1.ebuild')
-rw-r--r--games-arcade/cosmosmash/cosmosmash-1.4.7-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/cosmosmash/cosmosmash-1.4.7-r1.ebuild b/games-arcade/cosmosmash/cosmosmash-1.4.7-r1.ebuild
new file mode 100644
index 000000000000..b8b44c33ea54
--- /dev/null
+++ b/games-arcade/cosmosmash/cosmosmash-1.4.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A space rock shooting video game"
+HOMEPAGE="http://perso.b2b2c.ca/sarrazip/dev/cosmosmash.html"
+SRC_URI="http://perso.b2b2c.ca/sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # uses the sound card which portage user might not be available.
+
+RDEPEND=">=dev-games/flatzebra-0.1.6"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
+ -e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
+ -e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
+ src/Makefile.am \
+ || die
+ eautoreconf
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+ einstalldocs
+ doman doc/${PN}.6
+}