summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/criticalmass/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/criticalmass/files')
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch27
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch101
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch11
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch31
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch33
5 files changed, 203 insertions, 0 deletions
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch
new file mode 100644
index 000000000000..8b801e51c2cb
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-cflags.patch
@@ -0,0 +1,27 @@
+--- configure.in.orig 2011-07-20 11:23:19.849122541 -0400
++++ configure.in 2011-07-20 11:24:28.169713094 -0400
+@@ -35,9 +35,6 @@
+ AM_CONDITIONAL(APPLE,test "x$TARGET" = xAPPLE)
+ AM_CONDITIONAL(WIN32,test "x$TARGET" = xWIN32)
+
+-CFLAGS=""
+-CXXFLAGS=""
+-
+ if test "x$GCC" = xyes; then
+ CFLAGS="$CFLAGS -W -Wall"
+ CXXFLAGS="$CXXFLAGS -W -Wall -fno-exceptions"
+@@ -51,14 +48,6 @@
+ CXXFLAGS="$CXXFLAGS -g"
+ fi
+
+-AC_ARG_ENABLE(optimize,
+-[ --enable-optimize=level Enable optimization [default=2]],
+- enable_optmize=$enableval, enable_optimize=2)
+-if test "x$enable_optimize" != "xno" ; then
+- CFLAGS="$CFLAGS -O$enable_optimize"
+- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
+-fi
+-
+ AC_ARG_ENABLE(dyngl,
+ [ --enable-dyngl Load GL library dynamically [default=off]],
+ enable_dyngl=$enableval, enable_dyngl=off)
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch
new file mode 100644
index 000000000000..e57c11f5af28
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch
@@ -0,0 +1,101 @@
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxml.cpp 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxml.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -21,10 +21,12 @@
+ distribution.
+ */
+
+ #include "tinyxml.h"
+
++#include <cstring>
++
+
+ TiXmlNode::TiXmlNode( NodeType _type )
+ {
+ parent = 0;
+ type = _type;
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxml.h 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxml.h 2008-04-18 19:40:35.000000000 +0200
+@@ -28,10 +28,11 @@
+ #ifdef _MSC_VER
+ #pragma warning( disable : 4530 )
+ #pragma warning( disable : 4786 )
+ #endif
+
++#include <cstdlib>
+ #include <string>
+ #include <stdio.h>
+ #include <assert.h>
+
+ class TiXmlDocument;
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxmlparser.cpp 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxmlparser.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -23,10 +23,12 @@
+
+
+ #include "tinyxml.h"
+ #include <ctype.h>
+
++#include <cstring>
++
+ const char* TiXmlBase::SkipWhiteSpace( const char* p )
+ {
+ while ( p && *p &&
+ ( isspace( *p ) || *p == '\n' || *p == '\r' ) )
+ p++;
+--- CriticalMass-1.0.0.orig/utils/ResourceManager.cpp 2005-01-02 03:59:29.000000000 +0100
++++ CriticalMass-1.0.0/utils/ResourceManager.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -20,10 +20,12 @@
+ #include <ResourceManager.hpp>
+ #include <FindHash.hpp>
+ #include <Endian.hpp>
+ #include <WalkDirectory.hpp>
+
++#include <cstring>
++
+ #ifdef WIN32
+ const char PATH_SEPERATOR = '\\';
+ #else
+ const char PATH_SEPERATOR = '/';
+ #endif
+--- CriticalMass-1.0.0.orig/utils/Value.hpp 2004-12-18 03:41:24.000000000 +0100
++++ CriticalMass-1.0.0/utils/Value.hpp 2008-04-18 19:40:35.000000000 +0200
+@@ -13,10 +13,11 @@
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
+ #ifndef _Value_hpp_
+ #define _Value_hpp_
+
++#include <cstdlib>
+ #include <stdio.h>
+ #include <string>
+
+ #include <Trace.hpp>
+
+--- CriticalMass-1.0.0.orig/utils/zStreamBufferImplZLib.cpp 2005-07-31 22:06:14.000000000 +0200
++++ CriticalMass-1.0.0/utils/zStreamBufferImplZLib.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -10,10 +10,11 @@
+ //
+ // This program is distributed in the hope that it will be useful, but WITHOUT
+ // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
++#include <cstdlib>
+ #include <Trace.hpp>
+ #include <zStreamBufferImplZLib.hpp>
+
+ bool ziStreamBufferImplZLib::init( void)
+ {
+--- CriticalMass-1.0.0.orig/utils/zStream.cpp 2005-07-31 22:06:14.000000000 +0200
++++ CriticalMass-1.0.0/utils/zStream.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -10,10 +10,11 @@
+ //
+ // This program is distributed in the hope that it will be useful, but WITHOUT
+ // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
++#include <cstdlib>
+ #include <Trace.hpp>
+ #include <Endian.hpp>
+ #include <zStream.hpp>
+ #include <zStreamBufferImplLZMA.hpp>
+ #include <zStreamBufferImplZLib.hpp>
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch
new file mode 100644
index 000000000000..882869b43a14
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch
@@ -0,0 +1,11 @@
+--- configure.in
++++ configure.in
+@@ -99,7 +99,7 @@ if test "x$TARGET" = xWIN32; then
+ else
+ LIBS="-L/usr/local/lib -L/usr/X11R6/lib $LIBS"
+ CXXFLAGS="$CXXFLAGS -I/usr/X11R6/include"
+- AC_CHECK_LIB(png12, main,, AC_MSG_ERROR(libpng is needed))
++ AC_CHECK_LIB(png, main,, AC_MSG_ERROR(libpng is needed))
+ AC_CHECK_LIB(z, main,, AC_MSG_ERROR(libz is needed))
+ if test "x$TARGET" = xUNIX; then
+ if test "x$enable_dyngl" = xoff; then
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch
new file mode 100644
index 000000000000..ac1b8c0c617f
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng15.patch
@@ -0,0 +1,31 @@
+--- game/main.cpp
++++ game/main.cpp
+@@ -28,6 +28,8 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+
++#include <zlib.h>
++
+ void migrateConfig( void)
+ {
+ //if onlineCheck is not set, default it to true
+--- utilssdl/PNG.cpp
++++ utilssdl/PNG.cpp
+@@ -45,7 +45,7 @@
+ {
+ png_size_t check;
+
+- check = fwrite( data, 1, length, (FILE *)(png->io_ptr));
++ check = fwrite( data, 1, length, (FILE *)(png_get_io_ptr(png)));
+ if( check != length)
+ {
+ png_error( png, "Write Error");
+@@ -72,7 +72,7 @@
+ return false;
+ }
+
+- if( setjmp(_png->jmpbuf))
++ if( setjmp(png_jmpbuf(_png)))
+ {
+ fclose( fp);
+ png_destroy_write_struct(&_png, (png_infopp)NULL);
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch
new file mode 100644
index 000000000000..02307ad7d8fc
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch
@@ -0,0 +1,33 @@
+--- configure.in
++++ configure.in
+@@ -115,8 +115,6 @@ fi
+ AC_CHECK_LIB(m, sin,,
+ AC_MSG_ERROR(libm is needed))
+
+-AC_CONFIG_SUBDIRS(curl)
+-
+ AC_OUTPUT(Makefile utils/Makefile utilssdl/Makefile utilsgl/Makefile game/Makefile tools/Makefile data/Makefile data/music/Makefile tinyxml/Makefile)
+
+ echo "Configuration:
+--- game/Makefile.am
++++ game/Makefile.am
+@@ -41,7 +41,7 @@ critter_SOURCES = \
+ main.cpp
+
+ LDADD = \
+- ../curl/lib/libcurl.a \
++ -lcurl \
+ ../utils/libutils.a \
+ ../utilssdl/libutilssdl.a \
+ ../utilsgl/libutilsgl.a \
+--- Makefile.am
++++ Makefile.am
+@@ -4,7 +4,7 @@
+ AUTOMAKE_OPTIONS = 1.4
+
+ ## Any directories that you want built and installed should go here.
+-SUBDIRS = curl tinyxml utils utilssdl utilsgl tools data game
++SUBDIRS = tinyxml utils utilssdl utilsgl tools data game
+
+ ## Any directories you want a part of the distribution should be listed
+ ## here, as well as have a Makefile generated at the end of configure.in