summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/epiar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/epiar')
-rw-r--r--games-arcade/epiar/Manifest1
-rw-r--r--games-arcade/epiar/epiar-0.5-r1.ebuild51
-rw-r--r--games-arcade/epiar/files/0.5-gentoo-paths.patch59
-rw-r--r--games-arcade/epiar/files/epiar-0.5-Makefile.linux.patch20
-rw-r--r--games-arcade/epiar/files/epiar-0.5-gcc41.patch10
-rw-r--r--games-arcade/epiar/files/epiar-0.5-paths.patch86
-rw-r--r--games-arcade/epiar/files/epiar-0.5-underlink.patch10
-rw-r--r--games-arcade/epiar/metadata.xml18
8 files changed, 255 insertions, 0 deletions
diff --git a/games-arcade/epiar/Manifest b/games-arcade/epiar/Manifest
new file mode 100644
index 000000000000..9269c568669a
--- /dev/null
+++ b/games-arcade/epiar/Manifest
@@ -0,0 +1 @@
+DIST epiar-0.5.0-src.zip 8809392 SHA256 ec81babd5e5149d1104264fe218bebf83b84e1819c50066d17f71fb2184b21a4
diff --git a/games-arcade/epiar/epiar-0.5-r1.ebuild b/games-arcade/epiar/epiar-0.5-r1.ebuild
new file mode 100644
index 000000000000..c80f7b4ae0fc
--- /dev/null
+++ b/games-arcade/epiar/epiar-0.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils games
+
+DESCRIPTION="A space adventure/combat game"
+HOMEPAGE="http://epiar.net/"
+SRC_URI="mirror://sourceforge/epiar/${P}.0-src.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[png]"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+ virtual/opengl
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ sed -i \
+ -e "/^CFLAGS/s:-pg -g:${CFLAGS} ${LDFLAGS}:" \
+ Makefile.linux || die
+ epatch \
+ "${FILESDIR}"/${P}-paths.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-Makefile.linux.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" \
+ src/main.c || die
+}
+
+src_compile() {
+ emake -f Makefile.linux
+}
+
+src_install() {
+ dogamesbin epiar
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r missions *.eaf
+ keepdir "${GAMES_DATADIR}"/${PN}/plugins
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}
diff --git a/games-arcade/epiar/files/0.5-gentoo-paths.patch b/games-arcade/epiar/files/0.5-gentoo-paths.patch
new file mode 100644
index 000000000000..b46f56195aa7
--- /dev/null
+++ b/games-arcade/epiar/files/0.5-gentoo-paths.patch
@@ -0,0 +1,59 @@
+--- src/system/path.c.orig 2004-03-28 04:42:23.329963224 -0500
++++ src/system/path.c 2004-03-28 04:42:47.375307776 -0500
+@@ -187,6 +187,7 @@
+ free(stripped);
+ if (argv)
+ free(argv);
++ goto portage_path;
+ return (0);
+ }
+
+@@ -212,6 +213,11 @@
+ free(stripped);
+ if (argv)
+ free(argv);
++
++portage_path:
++ if (game_path) free(game_path);
++ game_path = (char *)malloc(sizeof(char) * strlen("/usr/share/games/epiar/\0"));
++ sprintf(game_path, "/usr/share/games/epiar/");
+
+ return (0);
+ }
+--- src/input/input.c.orig 2004-03-28 04:48:49.925191816 -0500
++++ src/input/input.c 2004-03-28 04:52:57.184602672 -0500
+@@ -240,7 +240,10 @@
+ *
+ ******************************************************************************/
+ int load_input_cfg(void) {
+- FILE *fp = fopen("./.epiar-input.ecf", "rb");
++ char filename[1024];
++ FILE *fp;
++ snprintf(filename, 1000, "%s/.epiar-input.ecf", getenv("HOME"));
++ fp = fopen(filename, "rb");
+
+ /* make sure all keys are enabled */
+ unlock_keys();
+@@ -282,7 +285,7 @@
+ } else {
+ float file_version = 0.0f;
+ /* read the file into the struct */
+- fp = fopen("./.epiar-input.ecf", "rb");
++ fp = fopen(filename, "rb");
+
+ if (fp == NULL) {
+ fprintf(stdout, "Could not open \"./.epiar-input.ecf\" for reading, assuming default bindings.\n");
+@@ -472,10 +475,12 @@
+ }
+
+ void save_keybindings(void) {
++ char filename[1024];
+ float file_version = 0.2f;
+ FILE *fp;
+
+- fp = fopen("./.epiar-input.ecf", "wb");
++ snprintf(filename, 1000, "%s/.epiar-input.ecf", getenv("HOME"));
++ fp = fopen(filename, "wb");
+ if (fp == NULL) {
+ fprintf(stdout, "Could not create '~/.epiar-input.ecf' to save keybindings\n");
+ return;
diff --git a/games-arcade/epiar/files/epiar-0.5-Makefile.linux.patch b/games-arcade/epiar/files/epiar-0.5-Makefile.linux.patch
new file mode 100644
index 000000000000..3086bd13ef9a
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5-Makefile.linux.patch
@@ -0,0 +1,20 @@
+--- Makefile.linux.old 2007-04-05 16:42:30 +0000
++++ Makefile.linux 2007-04-05 16:42:47 +0000
+@@ -24,7 +24,7 @@
+ @echo Building Epiar 0.5.0 ...
+ @$(CC) $(CFLAGS) -I/usr/X11R6/lib/ $(OBJS) -o epiar $(LIBS)
+ @echo Building plugins ...
+- @make -f Makefile.linux plugin
++ @$(MAKE) -f Makefile.linux plugin
+ @echo Epiar 0.5.0 build complete.
+ @echo
+ @echo Type './epiar' to play.
+@@ -33,7 +33,7 @@
+ @echo Building Epiar 0.5.0 and linking statically ...
+ @$(CC) $(CFLAGS) -L/usr/X11R6/lib -L/opt/gnome-2.1/lib $(OBJS) -o epiar $(STATIC_LIBS)
+ @echo Building plugins ...
+- @make plugin
++ @$(MAKE) plugin
+ @echo Epiar 0.5.0 build complete.
+ @echo
+ @echo Type './epiar' to play.
diff --git a/games-arcade/epiar/files/epiar-0.5-gcc41.patch b/games-arcade/epiar/files/epiar-0.5-gcc41.patch
new file mode 100644
index 000000000000..65f08b2691d1
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5-gcc41.patch
@@ -0,0 +1,10 @@
+--- src/game/game.h.old 2006-04-23 22:13:36.000000000 +0200
++++ src/game/game.h 2006-04-23 22:13:50.000000000 +0200
+@@ -2,7 +2,6 @@
+ #include "includes.h"
+
+ extern Uint32 average_loop_time;
+-extern Uint32 game_start_time;
+ extern Uint32 total_play_time, total_frames_drawn;
+ extern float average_session_fps, current_fps;
+
diff --git a/games-arcade/epiar/files/epiar-0.5-paths.patch b/games-arcade/epiar/files/epiar-0.5-paths.patch
new file mode 100644
index 000000000000..41266c7272b1
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5-paths.patch
@@ -0,0 +1,86 @@
+--- src/input/input.c
++++ src/input/input.c
+@@ -240,7 +240,10 @@
+ *
+ ******************************************************************************/
+ int load_input_cfg(void) {
+- FILE *fp = fopen("./.epiar-input.ecf", "rb");
++ char filename[PATH_MAX];
++ FILE *fp;
++ snprintf(filename, sizeof(filename), "%s/.epiar-input.ecf", getenv("HOME"));
++ fp = fopen(filename, "rb");
+
+ /* make sure all keys are enabled */
+ unlock_keys();
+@@ -282,7 +285,7 @@
+ } else {
+ float file_version = 0.0f;
+ /* read the file into the struct */
+- fp = fopen("./.epiar-input.ecf", "rb");
++ fp = fopen(filename, "rb");
+
+ if (fp == NULL) {
+ fprintf(stdout, "Could not open \"./.epiar-input.ecf\" for reading, assuming default bindings.\n");
+@@ -472,10 +475,12 @@
+ }
+
+ void save_keybindings(void) {
++ char filename[PATH_MAX];
+ float file_version = 0.2f;
+ FILE *fp;
+
+- fp = fopen("./.epiar-input.ecf", "wb");
++ snprintf(filename, sizeof(filename), "%s/.epiar-input.ecf", getenv("HOME"));
++ fp = fopen(filename, "wb");
+ if (fp == NULL) {
+ fprintf(stdout, "Could not create '~/.epiar-input.ecf' to save keybindings\n");
+ return;
+--- src/main.c
++++ src/main.c
+@@ -16,7 +16,7 @@
+ unsigned char view_mode = 0;
+ int ship_to_follow = 0;
+ int desired_bpp = 16;
+-char *game_path;
++const char * const game_path = "GENTOO_DATADIR";
+ unsigned char use_ogl = 0;
+ unsigned char skip_intro = 0;
+ FILE *epiar_eaf = NULL, *main_eaf = NULL;
+@@ -78,8 +78,6 @@
+
+ parse_commandline(argc, argv);
+
+- get_absolute_path(argv[0]);
+-
+ init(desired_bpp);
+
+ menu();
+--- src/main.h
++++ src/main.h
+@@ -1,2 +1,2 @@
+ extern char epiar_version[6];
+-extern char *game_path;
++extern const char * const game_path;
+--- src/system/init.c
++++ src/system/init.c
+@@ -89,9 +89,6 @@
+ main_eaf = NULL;
+ }
+
+- assert(game_path != NULL);
+- free(game_path);
+- game_path = NULL;
+
+ if (average_loop_time == 0) average_loop_time = 18; /* in case they quit on menu */
+ #ifndef NDEBUG
+--- src/system/path.c
++++ src/system/path.c
+@@ -45,7 +45,7 @@
+ }
+ #endif
+
+-#ifdef LINUX
++#if 0
+ char *strip_path_of_binary(char *argv) {
+ int len = 0, i, blen = 0;
+ char *stripped = NULL;
diff --git a/games-arcade/epiar/files/epiar-0.5-underlink.patch b/games-arcade/epiar/files/epiar-0.5-underlink.patch
new file mode 100644
index 000000000000..13146cb68b27
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5-underlink.patch
@@ -0,0 +1,10 @@
+--- Makefile.linux.old 2011-06-22 15:15:50.000000000 +0200
++++ Makefile.linux 2011-06-22 15:17:01.000000000 +0200
+@@ -1,6 +1,6 @@
+ CFLAGS=-W -Wall `sdl-config --cflags` -Isrc/ -DLINUX -DDEVEL -export-dynamic -I/usr/include/SDL -I/usr/local/include/SDL -DBLIT_METHOD_2 -DNAUDIO -O2 -march=pentium4 -pipe -mfpmath=sse -ggdb -Wl,-O1 -Wl,--as-needed
+
+-LIBS=-lm `sdl-config --libs` -lSDL_image
++LIBS=-lm `sdl-config --libs` -lSDL_image -ldl
+ STATIC_LIBS=-lm /usr/local/lib/libSDL.a /usr/local/lib/libSDL_image.a /usr/local/lib/libSDL_ttf.a /usr/local/lib/libopenal.a /usr/local/lib/libvorbisfile.a /usr/local/lib/libvorbis.a /usr/local/lib/libogg.a /usr/lib/libpng.a /usr/lib/libz.a -lpthread -ldl -lfreetype /usr/lib/libjpeg.a -lX11 -lXext -lesd
+
+ OBJS=main.o init.o video.o backbuffer.o debug.o audio.o linux_video.o \
diff --git a/games-arcade/epiar/metadata.xml b/games-arcade/epiar/metadata.xml
new file mode 100644
index 000000000000..a48c9cd9695c
--- /dev/null
+++ b/games-arcade/epiar/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+Epiar is a space adventure/combat game written in C with SDL
+(Simple DirectMedia Layer). It is absolutely free (released
+under the General Public License v2).
+In Epiar, you begin as a shuttle pilot in a galaxy generally
+ruled by anarchy, with few stable governments and numerous
+rebel factions. You start your adventure off doing whatever
+you want, but generally trying to save up money for a new
+starship, and your adventure takes off from there ...
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">epiar</remote-id>
+ </upstream>
+</pkgmetadata>