summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/jardinains/jardinains-2.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/jardinains/jardinains-2.0-r1.ebuild')
-rw-r--r--games-arcade/jardinains/jardinains-2.0-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-arcade/jardinains/jardinains-2.0-r1.ebuild b/games-arcade/jardinains/jardinains-2.0-r1.ebuild
new file mode 100644
index 000000000000..e177098a8152
--- /dev/null
+++ b/games-arcade/jardinains/jardinains-2.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Arkanoid with Gnomes"
+HOMEPAGE="http://www.jardinains2.com"
+SRC_URI="mirror://gentoo/JN2_1_FREE_LIN.tar.gz"
+
+LICENSE="jardinains"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+QA_EXECSTACK="${GAMES_PREFIX_OPT:1}/jardinains/jardinains"
+
+DEPEND=""
+RDEPEND="sys-libs/libstdc++-v3:5
+ amd64? ( sys-libs/libstdc++-v3:5[multilib] )
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXxf86vm-1.1.3[abi_x86_32(-)]"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/${PN}"
+
+src_unpack() {
+ unpack JN2_1_FREE_LIN.tar.gz
+ cd "${WORKDIR}" || die
+ mv "Jardinains 2!" ${P} || die
+}
+
+src_prepare() {
+ # clean Mac fork files (bug #295782)
+ find . -type f -name "._*" -exec rm -f '{}' +
+ epatch "${FILESDIR}"/strings-pt.patch
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe jardinains
+ insinto "${dir}"
+ doins -r LICENSE.txt data help
+
+ games_make_wrapper jardinains ./jardinains "${dir}" "${dir}"
+
+ make_desktop_entry jardinains "Jardinains 2"
+ touch "${D}${dir}/data/prefs.xml"
+ prepgamesdirs
+ chmod g+rw "${D}${dir}/data/prefs.xml"
+ chmod -R g+rw "${D}${dir}/data/players"
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Due to the way this software is designed all user preferences for"
+ elog "graphics, audio and other in game data are shared among all users"
+ elog "of the computer. For that reason some files in the installation"
+ elog "folder are writable by any user in the games group."
+}