summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild')
-rw-r--r--games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
index fc82628bc521..d6898a9647ff 100644
--- a/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
+++ b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
@@ -29,23 +29,23 @@ PATCHES=(
)
src_compile() {
- emake DATA_PATH="/usr/share/${PN}" || die "Compilation failed"
+ emake DATA_PATH="/usr/share/${PN}"
}
src_install() {
- dobin opentyrian || die "Failed to install game binary"
- dosym ../../usr/bin/opentyrian /usr/bin/tyrian || die "Failed to symlink"
- dodoc CREDITS NEWS README || die "Failed to install documentation"
+ dobin opentyrian
+ dosym ../../usr/bin/opentyrian /usr/bin/tyrian
+ dodoc CREDITS NEWS README
domenu linux/opentyrian.desktop || die "Failed to install desktop file"
for i in linux/icons/*.png ; do
local size=`echo ${i} | sed -e 's:.*-\([0-9]\+\).png:\1:'`
insinto /usr/share/icons/hicolor/${size}x${size}/apps
- newins ${i} opentyrian.png || die "Failed to install program icon"
+ newins ${i} opentyrian.png
done
insinto "/usr/share/${PN}"
cd "${WORKDIR}/tyrian21"
rm *.exe dpmi16bi.ovl loudness.awe || die "Failed to remove win32 binaries"
- doins * || die "Failed to install game data"
+ doins *
}
pkg_postinst() {