summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 06:16:51 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:32:23 +0000
commita13be1d469a84324792a9e2eafc235defc5a9655 (patch)
tree3bf2772fa7b9f6c5f9dedaf4f954be98b42fb37f /games-arcade/orthorobot
parentgames-arcade/retrobattle: eutils->wrapper (diff)
downloadgentoo-a13be1d469a84324792a9e2eafc235defc5a9655.tar.gz
gentoo-a13be1d469a84324792a9e2eafc235defc5a9655.tar.bz2
gentoo-a13be1d469a84324792a9e2eafc235defc5a9655.zip
games-arcade/orthorobot: eutils->{desktop, wrapper}
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/orthorobot')
-rw-r--r--games-arcade/orthorobot/orthorobot-0-r1.ebuild30
-rw-r--r--games-arcade/orthorobot/orthorobot-0-r2.ebuild30
2 files changed, 34 insertions, 26 deletions
diff --git a/games-arcade/orthorobot/orthorobot-0-r1.ebuild b/games-arcade/orthorobot/orthorobot-0-r1.ebuild
index 7d3771a8a4cf..387a153a6b68 100644
--- a/games-arcade/orthorobot/orthorobot-0-r1.ebuild
+++ b/games-arcade/orthorobot/orthorobot-0-r1.ebuild
@@ -1,39 +1,43 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit desktop wrapper
DESCRIPTION="Perspective based puzzle game, where you flatten the view to move across gaps"
HOMEPAGE="https://stabyourself.net/orthorobot/"
SRC_URI="https://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+S="${WORKDIR}"
LICENSE="CC-BY-NC-ND-3.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND=">=games-engines/love-0.8.0:0"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
+BDEPEND="app-arch/unzip"
src_unpack() {
default
- #it is only one .love file (but with crappy name), so we can use asterisk
- mv *.love "${P}.zip" || die 'mv failed'
+
+ # It is only one .love file (but with crappy name), so we can use asterisk
+ mv *.love "${P}.zip" || die "mv failed"
unpack "./${P}.zip"
- rm "${P}.zip" || die 'rm failed'
+
+ rm "${P}.zip" || die "rm failed"
}
src_prepare() {
default
- # fix error on quit
- sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
+
+ # Fix error on quit
+ sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die "sed failed"
}
src_install() {
- local dir="/usr/share/love/${PN}"
- insinto "${dir}"
+ local dir=/usr/share/love/${PN}
+ insinto ${dir}
+
doins -r .
make_wrapper "${PN}" "love ${dir}"
make_desktop_entry "${PN}"
diff --git a/games-arcade/orthorobot/orthorobot-0-r2.ebuild b/games-arcade/orthorobot/orthorobot-0-r2.ebuild
index 305cf7ee67ed..1da2dac05619 100644
--- a/games-arcade/orthorobot/orthorobot-0-r2.ebuild
+++ b/games-arcade/orthorobot/orthorobot-0-r2.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit desktop wrapper
DESCRIPTION="Perspective based puzzle game, where you flatten the view to move across gaps"
HOMEPAGE="https://stabyourself.net/orthorobot/"
SRC_URI="https://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+S="${WORKDIR}"
LICENSE="CC-BY-NC-ND-3.0"
SLOT="0"
@@ -14,28 +16,30 @@ KEYWORDS="~amd64 ~x86"
LVSLOT="0.8"
RDEPEND="games-engines/love:${LVSLOT}"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
+BDEPEND="app-arch/unzip"
src_unpack() {
default
- #it is only one .love file (but with crappy name), so we can use asterisk
- mv *.love "${P}.zip" || die 'mv failed'
+
+ # It is only one .love file (but with crappy name), so we can use asterisk
+ mv *.love "${P}.zip" || die "mv failed"
unpack "./${P}.zip"
- rm "${P}.zip" || die 'rm failed'
+
+ rm "${P}.zip" || die "rm failed"
}
src_prepare() {
default
- # fix error on quit
- sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
+ # Fix error on quit
+ sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die "sed failed"
}
src_install() {
- local dir="/usr/share/love/${PN}"
- insinto "${dir}"
+ local dir=/usr/share/love/${PN}
+
+ insinto ${dir}
doins -r .
+
make_wrapper "${PN}" "love-${LVSLOT} ${dir}"
make_desktop_entry "${PN}"
}