summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/pachi/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/pachi/files')
-rw-r--r--games-arcade/pachi/files/1.0-autotools.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/pachi/files/1.0-autotools.patch b/games-arcade/pachi/files/1.0-autotools.patch
new file mode 100644
index 000000000000..0d0185f142f3
--- /dev/null
+++ b/games-arcade/pachi/files/1.0-autotools.patch
@@ -0,0 +1,46 @@
+--- configure.in
++++ configure.in
+@@ -1,5 +1,7 @@
+ # Process this file with autoconf to produce a configure script.
++AC_PREREQ([2.54])
+ AC_INIT(src/faes.cpp, 0.1, T-1000@Bigfoot.com)
++AC_CANONICAL_SYSTEM
+ AM_INIT_AUTOMAKE(pachi, 0.1)
+ AM_CONFIG_HEADER(config.h)
+
+@@ -44,7 +46,7 @@
+ SCOREDIR="."
+ else
+ DATADIR="$datadir/$PACKAGE"
+- SCOREDIR="/var/lib/games/$PACKAGE"
++ SCOREDIR="$localstatedir/$PACKAGE"
+ fi
+
+ eval DATAPATH=`eval echo "$DATADIR"`
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -10,13 +10,13 @@
+ objects_v2.dat \
+ rooms_v2.dat
+
+-score_DATA = \
++score_DATA_ = \
+ scores.dat
+
+-EXTRA_DIST = $(dat_DATA) $(score_DATA)
++EXTRA_DIST = $(dat_DATA) $(score_DATA_)
+
+ install-data-local:
+- for file in $(score_DATA); do\
+- chgrp $(group) $(scoredir)/$$file; \
+- chmod $(perms) $(scoredir)/$$file; \
+- done
++ $(mkinstalldirs) $(DESTDIR)$(scoredir)
++ for file in $(score_DATA_); do \
++ $(INSTALL) -g $(group) -m $(perms) $$file $(DESTDIR)$(scoredir); \
++ done
+--- Makefile.am
++++ Makefile.am
+@@ -1 +1 @@
+-SUBDIRS = src Tgfx data fonts music sounds docs
++SUBDIRS = src Tgfx data fonts music sounds