summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/retrobattle/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/retrobattle/files')
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch30
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch17
2 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
new file mode 100644
index 000000000000..3673ef01e17f
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
@@ -0,0 +1,30 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Sat Aug 4 12:15:53 2012 +0200
+
+ respect CXX, CFLAGS and LDFLAGS
+
+--- src/Makefile
++++ src/Makefile
+@@ -1,10 +1,10 @@
+-CFLAGS = `sdl-config --cflags` -g -Wall -I. -DENABLE_BINRELOC
+-CPPFLAGS = $(CFLAGS)
++CXXFLAGS += $(shell sdl-config --cflags) -I.
++CPPFLAGS += -DENABLE_BINRELOC
+
+ # Uncomment the first LIBS line and comment out the other LIBS line to
+ # compile without SDL_Mixer
+ #LIBS = `sdl-config --libs`
+-LIBS = `sdl-config --libs` -lSDL_mixer
++LIBS = $(shell sdl-config --libs) -lSDL_mixer
+
+ RETROINSTALLDIR ?= /opt
+
+@@ -25,7 +25,7 @@
+
+
+ retrobattle: $(RETRO)
+- g++ -o $@ $^ $(LIBS)
++ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+ mv $@ ..
+
+ clean:
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch
new file mode 100644
index 000000000000..591ce66e9f69
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Aug 5 16:22:22 UTC 2012
+Subject: sound
+
+resolves crackling background music
+
+--- src/SoundManager.cc
++++ src/SoundManager.cc
+@@ -25,7 +25,7 @@
+ SoundManager::SoundManager(char *datadir)
+ {
+ #ifndef NO_SDL_MIXER
+- if(Mix_OpenAudio(22050, AUDIO_S16SYS, 2, 1024))
++ if(Mix_OpenAudio(44100, AUDIO_S16SYS, 2, 1024))
+ {
+ printf("SDL_mixer says: %s\n", Mix_GetError());
+ }