summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/sable/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/sable/files')
-rw-r--r--games-arcade/sable/files/sable-1.0-gentoo.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-arcade/sable/files/sable-1.0-gentoo.patch b/games-arcade/sable/files/sable-1.0-gentoo.patch
new file mode 100644
index 000000000000..b809936ff964
--- /dev/null
+++ b/games-arcade/sable/files/sable-1.0-gentoo.patch
@@ -0,0 +1,57 @@
+diff -ru sable.orig/src/Makefile sable/src/Makefile
+--- sable.orig/src/Makefile 2006-03-14 00:57:31.000000000 -0500
++++ sable/src/Makefile 2009-01-21 15:15:02.000000000 -0500
+@@ -1,30 +1,10 @@
+-# are we on OSX?
+-ifeq ($(shell uname), Darwin)
+-OSX:=1
+-endif
+-
+-# C options
+-CC = gcc
+-NOOSXFLAGS = -c `sdl-config --cflags` -O2 -Wall -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude $(CFLAGS)
+-ifdef OSX
+-FLAGS = $(NOOSXFLAGS) -D_SABLE_OSX_
+-else
+-FLAGS = $(NOOSXFLAGS)
+-endif
+-
+-# C++ options.
+-CXX = g++
+-CXXFLAGS = $(FLAGS)
++NOOSXFLAGS = -c `sdl-config --cflags` -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude
++
++CFLAGS += $(NOOSXFLAGS)
++CXXFLAGS += $(NOOSXFLAGS)
+
+ # Linker options.
+-LD = g++
+-LDFLAGS =
+-NOOSXLIBS = -lSDL_image -lSDL_mixer
+-ifdef OSX
+-LIBS = `sdl-config --static-libs` $(NOOSXLIBS)
+-else
+-LIBS = `sdl-config --libs` $(NOOSXLIBS) -lGL -lGLU
+-endif
++LIBS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
+
+ COBJS = vcontrol/vcontrol.o \
+ bcplrandom.o \
+@@ -35,7 +15,7 @@
+ OBJS = $(COBJS) $(CXXOBJS)
+
+ sable: $(OBJS)
+- $(LD) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
+
+ clean:
+ rm -f sable *.o vcontrol/*.o svaf/*.o
+@@ -44,7 +24,7 @@
+ find . -name \*.c\* | xargs makedepend -Y. -Iinclude >& /dev/null
+
+ $(COBJS): %.o: %.c
+- $(CC) $(FLAGS) -o $@ $<
++ $(CC) $(CFLAGS) -o $@ $<
+
+ $(CXXOBJS): %.o: %.cpp
+ $(CXX) $(CXXFLAGS) -o $@ $<