summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/smc/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/smc/files')
-rw-r--r--games-arcade/smc/files/smc-1.9-boost150.patch101
-rw-r--r--games-arcade/smc/files/smc-1.9-underlink.patch25
2 files changed, 126 insertions, 0 deletions
diff --git a/games-arcade/smc/files/smc-1.9-boost150.patch b/games-arcade/smc/files/smc-1.9-boost150.patch
new file mode 100644
index 000000000000..42d7ce2bc66c
--- /dev/null
+++ b/games-arcade/smc/files/smc-1.9-boost150.patch
@@ -0,0 +1,101 @@
+--- src/overworld/world_manager.cpp.old 2012-11-14 17:05:19.759087973 +0100
++++ src/overworld/world_manager.cpp 2012-11-14 17:06:55.365644219 +0100
+@@ -111,14 +111,14 @@
+ void cOverworld_Manager :: Load_Dir( const std::string &dir, bool user_dir /* = 0 */ )
+ {
+ // set world directory
+- fs::path full_path( dir, fs::native );
++ fs::path full_path( dir );
+ fs::directory_iterator end_iter;
+
+ for( fs::directory_iterator dir_itr( full_path ); dir_itr != end_iter; ++dir_itr )
+ {
+ try
+ {
+- std::string current_dir = dir_itr->path().leaf();
++ std::string current_dir = dir_itr->path().filename().string();
+
+ // only directories with an existing description
+ if( fs::is_directory( *dir_itr ) && File_Exists( dir + "/" + current_dir + "/description.xml" ) )
+--- src/video/video.cpp.old 2012-11-14 17:10:26.448625365 +0100
++++ src/video/video.cpp 2012-11-14 17:11:37.486580531 +0100
+@@ -749,7 +749,7 @@
+ {
+ try
+ {
+- fs::remove_all( fs::path( m_imgcache_dir, fs::native ) );
++ fs::remove_all( fs::path( m_imgcache_dir ) );
+ }
+ // could happen if a file is locked or we have no write rights
+ catch( const std::exception &ex )
+@@ -771,7 +771,7 @@
+ // no cache available
+ if( !Dir_Exists( imgcache_dir_active ) )
+ {
+- fs::create_directories( fs::path( imgcache_dir_active + "/" GAME_PIXMAPS_DIR, fs::native ) );
++ fs::create_directories( fs::path( imgcache_dir_active + "/" GAME_PIXMAPS_DIR ) );
+ }
+ // cache available
+ else
+--- src/core/filesystem/filesystem.cpp.old 2012-11-14 09:00:41.965617165 +0100
++++ src/core/filesystem/filesystem.cpp 2012-11-14 16:57:11.282043980 +0100
+@@ -64,7 +64,7 @@
+
+ bool Dir_Exists( const std::string &dir )
+ {
+- return fs::exists( fs::path( dir, fs::native ) );
++ return fs::exists( fs::path( dir ) );
+
+ /*struct stat file_info;
+
+@@ -89,7 +89,7 @@
+
+ bool Create_Directory( const std::string &dir )
+ {
+- return fs::create_directory( fs::path( dir, fs::native ) );
++ return fs::create_directory( fs::path( dir ) );
+ }
+
+ size_t Get_File_Size( const std::string &filename )
+@@ -130,7 +130,7 @@
+ {
+ vector<std::string> valid_files;
+
+- fs::path full_path( dir, fs::native );
++ fs::path full_path( dir );
+ fs::directory_iterator end_iter;
+
+ // load all available objects
+@@ -142,27 +142,27 @@
+ if( fs::is_directory( *dir_itr ) )
+ {
+ // ignore hidden directories
+- if( dir_itr->path().leaf().find( "." ) == 0 )
++ if( dir_itr->path().filename().string().find( "." ) == 0 )
+ {
+ continue;
+ }
+
+ if( with_directories )
+ {
+- valid_files.push_back( dir + "/" + dir_itr->path().leaf() );
++ valid_files.push_back( dir + "/" + dir_itr->path().filename().string() );
+ }
+
+ // load all items from the sub-directory
+ if( search_in_sub_directories )
+ {
+- vector<std::string> new_valid_files = Get_Directory_Files( dir + "/" + dir_itr->path().leaf(), file_type, with_directories );
++ vector<std::string> new_valid_files = Get_Directory_Files( dir + "/" + dir_itr->path().filename().string(), file_type, with_directories );
+ valid_files.insert( valid_files.end(), new_valid_files.begin(), new_valid_files.end() );
+ }
+ }
+ // valid file
+- else if( file_type.empty() || dir_itr->path().leaf().rfind( file_type ) != std::string::npos )
++ else if( file_type.empty() || dir_itr->path().filename().string().rfind( file_type ) != std::string::npos )
+ {
+- valid_files.push_back( dir + "/" + dir_itr->path().leaf() );
++ valid_files.push_back( dir + "/" + dir_itr->path().filename().string() );
+ }
+ }
+ catch( const std::exception &ex )
diff --git a/games-arcade/smc/files/smc-1.9-underlink.patch b/games-arcade/smc/files/smc-1.9-underlink.patch
new file mode 100644
index 000000000000..6e076027c472
--- /dev/null
+++ b/games-arcade/smc/files/smc-1.9-underlink.patch
@@ -0,0 +1,25 @@
+diff -burN smc-1.9.orig/configure.ac smc-1.9/configure.ac
+--- smc-1.9.orig/configure.ac 2013-10-23 19:11:08.635054067 +0200
++++ smc-1.9/configure.ac 2013-10-23 19:42:29.820272295 +0200
+@@ -12,6 +12,10 @@
+ ### Check for libraries ###
+
+ # Check for the Boost Filesystem library
++AC_CHECK_LIB(boost_system, main, ,
++ AC_MSG_ERROR([Unable to find Boost System library]))
++
++# Check for the Boost Filesystem library
+ AC_CHECK_LIB(boost_filesystem, main, ,
+ AC_MSG_ERROR([Unable to find Boost Filesystem library]))
+
+@@ -36,6 +40,10 @@
+ CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
+
++# Check for the X11 library
++AC_CHECK_LIB(X11, XOpenDisplay, ,
++ AC_MSG_ERROR([X11 library not found]))
++
+ # Check for the libpng library
+ AC_CHECK_LIB(png, png_init_io, ,
+ AC_MSG_ERROR([libpng library not found]))