summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-19 16:37:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-19 16:37:18 +0100
commitfbc5d7b32ed370279238af30bca5ebf00b6b8a0b (patch)
treec8ce96c4eb9d0c4dd95a159300dc42248f8e5886 /games-arcade/supertux/supertux-0.6.1.ebuild
parentsys-apps/file: Bump to version 5.38 (diff)
downloadgentoo-fbc5d7b32ed370279238af30bca5ebf00b6b8a0b.tar.gz
gentoo-fbc5d7b32ed370279238af30bca5ebf00b6b8a0b.tar.bz2
gentoo-fbc5d7b32ed370279238af30bca5ebf00b6b8a0b.zip
games-arcade/supertux: Bump to version 0.6.1
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-arcade/supertux/supertux-0.6.1.ebuild')
-rw-r--r--games-arcade/supertux/supertux-0.6.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-arcade/supertux/supertux-0.6.1.ebuild b/games-arcade/supertux/supertux-0.6.1.ebuild
new file mode 100644
index 000000000000..dce1075f2829
--- /dev/null
+++ b/games-arcade/supertux/supertux-0.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+: ${CMAKE_MAKEFILE_GENERATOR:=emake}
+inherit cmake-utils flag-o-matic
+
+MY_P="SuperTux-v${PV}-Source"
+
+DESCRIPTION="A game similar to Super Mario Bros."
+HOMEPAGE="https://supertux.org/"
+SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-games/physfs-3.0
+ dev-libs/boost:=
+ media-libs/glew:=
+ virtual/opengl
+ media-libs/libvorbis
+ media-libs/openal
+ >=media-libs/libsdl2-2.0.1[joystick,video]
+ >=media-libs/sdl2-image-2.0.0[png,jpeg]
+ >=net-misc/curl-7.21.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.0-tinygettext.patch
+ "${FILESDIR}"/${PN}-0.6.0-{license,icon,obstack}.patch
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # This is not a developer release so switch the logo to the non-dev one.
+ sed -e 's@logo_dev@logo@' \
+ -i data/images/objects/logo/logo.sprite || die
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DWERROR=OFF
+ -DINSTALL_SUBDIR_BIN=bin
+ -DINSTALL_SUBDIR_DOC=share/doc/${PF}
+ -DINSTALL_SUBDIR_SHARE=share/${PN}2
+ -DENABLE_SQDBG="$(usex debug)"
+ -DUSE_SYSTEM_PHYSFS=ON
+ )
+ cmake-utils_src_configure
+}