summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-05 02:23:17 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-05 02:23:17 +0200
commitefd1894c63543eaacbcfd078113111399ee03583 (patch)
tree3575c84412b8a8a01c2a076586fd384c8f3a3257 /games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
parentdev-libs/libbulletml: Pass AR/CXX to build system (diff)
downloadgentoo-efd1894c63543eaacbcfd078113111399ee03583.tar.gz
gentoo-efd1894c63543eaacbcfd078113111399ee03583.tar.bz2
gentoo-efd1894c63543eaacbcfd078113111399ee03583.zip
games-arcade/tuxpuck: Fix build system
Closes: https://bugs.gentoo.org/724420 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild')
-rw-r--r--games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild46
1 files changed, 22 insertions, 24 deletions
diff --git a/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild b/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
index d853da6c5d16..d2fdb0c45bcc 100644
--- a/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
+++ b/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit desktop
+EAPI=7
+
+inherit desktop toolchain-funcs
DESCRIPTION="Hover hockey"
HOMEPAGE="http://home.no.net/munsuun/tuxpuck/"
@@ -11,38 +12,32 @@ SRC_URI="http://home.no.net/munsuun/tuxpuck/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
RDEPEND="
media-libs/libsdl
media-libs/libpng:0=
- virtual/jpeg:0
media-libs/libvorbis
-"
+ virtual/jpeg:0"
DEPEND="${RDEPEND}
- media-libs/freetype:2
- virtual/pkgconfig
-"
+ media-libs/freetype:2"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Makefile.patch
+ "${FILESDIR}"/${P}-png15.patch
+)
src_prepare() {
default
+
# Bug #376741 - Make unpack call compatible with both
# PMS and <sys-apps/portage-2.1.10.10.
cd man || die
unpack ./${PN}.6.gz
- cd .. || die
- sed -i \
- -e 's/-Werror//' \
- -e '/^CC/d' \
- Makefile \
- utils/Makefile \
- data/Makefile \
- || die "sed failed"
-
- eapply "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${P}-png15.patch \
- "${FILESDIR}"/${P}-parallel.patch \
- "${FILESDIR}"/${P}-freetype_pkgconfig.patch
+}
+
+src_configure() {
+ tc-export AR CC PKG_CONFIG RANLIB
}
src_compile() {
@@ -53,9 +48,12 @@ src_compile() {
src_install() {
dobin tuxpuck
- doman man/tuxpuck.6
+
dodoc *.txt
+ einstalldocs
+
+ doman man/tuxpuck.6
+
doicon data/icons/${PN}.ico
make_desktop_entry ${PN} "TuxPuck" /usr/share/pixmaps/${PN}.ico
- einstalldocs
}