summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/wop/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/wop/files')
-rw-r--r--games-arcade/wop/files/wop-0.4.3-Makefile.patch54
-rw-r--r--games-arcade/wop/files/wop-0.4.3-gcc43.patch32
2 files changed, 86 insertions, 0 deletions
diff --git a/games-arcade/wop/files/wop-0.4.3-Makefile.patch b/games-arcade/wop/files/wop-0.4.3-Makefile.patch
new file mode 100644
index 000000000000..a7d2e67f9dc6
--- /dev/null
+++ b/games-arcade/wop/files/wop-0.4.3-Makefile.patch
@@ -0,0 +1,54 @@
+--- Makefile.orig 2007-04-23 18:27:32 +0000
++++ Makefile 2007-04-23 18:27:50 +0000
+@@ -3,22 +3,22 @@
+ sinclude Makefile.local
+
+ all:
+- +cd sdlwidgets; make
+- +cd src; make
++ +cd sdlwidgets; $(MAKE)
++ +cd src; $(MAKE)
+ runc:
+- +cd src; make runc
++ +cd src; $(MAKE) runc
+ runs:
+- +cd src; make runs
++ +cd src; $(MAKE) runs
+ doc:
+- cd src; make doc
++ cd src; $(MAKE) doc
+ clean:
+- cd sdlwidgets; make clean
+- cd src; make clean
++ cd sdlwidgets; $(MAKE) clean
++ cd src; $(MAKE) clean
+ cd doc; rm -rf html
+ unison:
+- cd src; make unison
++ cd src; $(MAKE) unison
+ gunison:
+- cd src; make gunison
++ cd src; $(MAKE) gunison
+ snapshot-src:
+ ln -s . wop; \
+ tar cjvf wop-`date +%F`.tar.bz2 \
+--- src/Makefile.orig 2006-02-13 10:14:01.000000000 +0100
++++ src/Makefile 2007-04-27 18:36:22.000000000 +0200
+@@ -18,7 +18,7 @@
+ -DUSE_SDL -DNEW=new\(std::nothrow\) \
+ -I../sdlwidgets \
+ $(shell sdl-config --cflags) # -g
+-LDFLAGS = -L../sdlwidgets -lsdlwidgets -lz \
++LIBS = -L../sdlwidgets -lsdlwidgets -lz \
+ -lm -lSDL_net -lSDL_mixer -lSDL_ttf -lSDL_image \
+ $(shell sdl-config --libs) # -g
+
+@@ -56,7 +56,7 @@
+
+ $(TARGET): $(OBJECT_FILES) Makefile ../sdlwidgets/libsdlwidgets.a
+ -mkdir ../bin
+- $(CXX) $(OBJECT_FILES) -o $(TARGET) $(LDFLAGS)
++ $(CXX) $(LDFLAGS) $(OBJECT_FILES) -o $(TARGET) $(LIBS)
+
+ %.o: %.cpp Makefile
+ $(CXX) $(CXXFLAGS) -c $< -o $@ \ No newline at end of file
diff --git a/games-arcade/wop/files/wop-0.4.3-gcc43.patch b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
new file mode 100644
index 000000000000..903a97ba92ce
--- /dev/null
+++ b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
@@ -0,0 +1,32 @@
+--- src/scusibot.cpp.old 2010-01-05 15:41:23.000000000 +0100
++++ src/scusibot.cpp 2010-01-05 15:41:46.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "stationarygun.hpp"
+ #include "global.hpp"
+ #include <vector>
++#include <algorithm>
+
+ ScusiBot::ScusiBot()
+ : m_event( Event::EMPTY ), m_count( 0 ), m_state( IDLE ) {
+--- src/gameinfowindow.cpp.old 2010-01-05 15:45:09.000000000 +0100
++++ src/gameinfowindow.cpp 2010-01-05 15:46:08.000000000 +0100
+@@ -10,6 +10,8 @@
+ #include "avatarworm.hpp"
+ #include "wopsprites.hpp"
+ #include "wopsprites.cpp"
++#include "spriteset.cpp"
++#include "spritesequence.cpp"
+ #include "scorekeeper.hpp"
+ #include "wopgui.hpp"
+
+--- src/map.cpp.old 2010-01-05 15:46:35.000000000 +0100
++++ src/map.cpp 2010-01-05 15:47:06.000000000 +0100
+@@ -9,6 +9,8 @@
+ #include "world.hpp"
+ #include "wopsettings.hpp"
+ #include "objectpaths.hpp"
++#include "spriteset.cpp"
++#include "spritesequence.cpp"
+
+ /**********************************************************/
+