summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-08-30 01:07:10 +0300
committerStefan Strogin <steils@gentoo.org>2019-08-30 01:13:34 +0300
commit32c743a4df5a0b11915e3dfd92f55dd4850ef89e (patch)
treec675cd34faad57894c734da5827f027960df31e6 /games-arcade/xbill
parentgames-server/monopd: fix build with >=dev-libs/utfcpp-2.3.6 (diff)
downloadgentoo-32c743a4df5a0b11915e3dfd92f55dd4850ef89e.tar.gz
gentoo-32c743a4df5a0b11915e3dfd92f55dd4850ef89e.tar.bz2
gentoo-32c743a4df5a0b11915e3dfd92f55dd4850ef89e.zip
games-arcade/xbill: add missing dependency; EAPI=7
- Add media-fonts/font-misc-misc and acct-group/gamestat to RDEPEND. - mv configure.in configure.ac (see bug 426262). - QA issues (permissions of /var/lib/xbill/scores). Reported-by: Haelwenn Monnier <contact@hacktivis.me> Closes: https://bugs.gentoo.org/692318 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'games-arcade/xbill')
-rw-r--r--games-arcade/xbill/files/xbill-2.1-gtk2.patch4
-rw-r--r--games-arcade/xbill/xbill-2.1-r3.ebuild (renamed from games-arcade/xbill/xbill-2.1-r2.ebuild)30
2 files changed, 21 insertions, 13 deletions
diff --git a/games-arcade/xbill/files/xbill-2.1-gtk2.patch b/games-arcade/xbill/files/xbill-2.1-gtk2.patch
index 70817b09c7ab..829475badd72 100644
--- a/games-arcade/xbill/files/xbill-2.1-gtk2.patch
+++ b/games-arcade/xbill/files/xbill-2.1-gtk2.patch
@@ -1,5 +1,5 @@
---- configure.in.old 2007-12-05 22:37:57.000000000 +0100
-+++ configure.in 2007-12-05 22:54:57.000000000 +0100
+--- a/configure.in 2007-12-05 22:37:57.000000000 +0100
++++ b/configure.in 2007-12-05 22:54:57.000000000 +0100
@@ -88,12 +88,11 @@
[ --enable-gtk build with the GTK widget set])
diff --git a/games-arcade/xbill/xbill-2.1-r2.ebuild b/games-arcade/xbill/xbill-2.1-r3.ebuild
index 1152f2caca38..70378b00ceb9 100644
--- a/games-arcade/xbill/xbill-2.1-r2.ebuild
+++ b/games-arcade/xbill/xbill-2.1-r3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools games
+EAPI=7
+
+inherit autotools desktop
DESCRIPTION="A game about an evil hacker called Bill!"
HOMEPAGE="http://www.xbill.org/"
@@ -13,20 +14,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
IUSE="gtk"
-RDEPEND="gtk? ( x11-libs/gtk+:2 )
+RDEPEND="acct-group/gamestat
+ media-fonts/font-misc-misc
+ gtk? ( x11-libs/gtk+:2 )
!gtk? ( x11-libs/libXaw )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gtk2.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gtk2.patch \
- "${FILESDIR}"/${P}-gentoo.patch
+ default
+ mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
- egamesconf \
+ econf \
--disable-motif \
$(use_enable gtk) \
$(use_enable !gtk athena)
@@ -36,5 +43,6 @@ src_install() {
default
newicon pixmaps/icon.xpm ${PN}.xpm
make_desktop_entry ${PN} XBill ${PN}
- prepgamesdirs
+ fowners :gamestat /var/lib/xbill/scores
+ fperms 664 /var/lib/xbill/scores
}