summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-25 20:26:02 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-25 20:29:40 +0200
commite8f837187411c684183debc5f8bbc5d0d6c60b31 (patch)
treef2079668c9d4d794c8a96bb44a69cfbde22100aa /games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild
parentgames-arcade/xtux: Drop old (diff)
downloadgentoo-e8f837187411c684183debc5f8bbc5d0d6c60b31.tar.gz
gentoo-e8f837187411c684183debc5f8bbc5d0d6c60b31.tar.bz2
gentoo-e8f837187411c684183debc5f8bbc5d0d6c60b31.zip
games-arcade/yarsrevenge: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild')
-rw-r--r--games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild b/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild
new file mode 100644
index 000000000000..b6923570b8f4
--- /dev/null
+++ b/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Remake of the Atari 2600 classic Yar's Revenge"
+HOMEPAGE="http://freshmeat.net/projects/yarsrevenge/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/yar-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/yar-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-math.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_install() {
+ default
+ make_desktop_entry "${PN}" "Yar's Revenge"
+}