summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-05 07:38:33 +0000
committerSam James <sam@gentoo.org>2023-01-05 07:45:28 +0000
commit5e7551573baae3b8530295e07cf19afd5a9f2705 (patch)
treeffa7526833cc081b72e3ee4d0695341dcf03cd30 /games-arcade/yarsrevenge
parentx11-misc/lineak-xosdplugin: fix configure w/ clang 16 (diff)
downloadgentoo-5e7551573baae3b8530295e07cf19afd5a9f2705.tar.gz
gentoo-5e7551573baae3b8530295e07cf19afd5a9f2705.tar.bz2
gentoo-5e7551573baae3b8530295e07cf19afd5a9f2705.zip
games-arcade/yarsrevenge: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/879689 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/yarsrevenge')
-rw-r--r--games-arcade/yarsrevenge/files/yarsrevenge-0.99-configure-clang16.patch14
-rw-r--r--games-arcade/yarsrevenge/yarsrevenge-0.99-r2.ebuild (renamed from games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild)7
2 files changed, 18 insertions, 3 deletions
diff --git a/games-arcade/yarsrevenge/files/yarsrevenge-0.99-configure-clang16.patch b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-configure-clang16.patch
new file mode 100644
index 000000000000..eae341836880
--- /dev/null
+++ b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-configure-clang16.patch
@@ -0,0 +1,14 @@
+autoreconf fails and it's a trivial fix to the generated configure, so let's
+just patch that instead. This is fixed in autoconf itself in newer versions.
+
+https://bugs.gentoo.org/879689
+--- a/configure
++++ b/configure
+@@ -6289,6 +6289,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <ctype.h>
++#include <stdlib.h>
+ #if ((' ' & 0x0FF) == 0x020)
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+ # define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
diff --git a/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild b/games-arcade/yarsrevenge/yarsrevenge-0.99-r2.ebuild
index 6ec048d1f79f..cc35efd61d0e 100644
--- a/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild
+++ b/games-arcade/yarsrevenge/yarsrevenge-0.99-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit desktop
DESCRIPTION="Remake of the Atari 2600 classic Yar's Revenge"
@@ -11,7 +12,6 @@ SRC_URI="http://www.autismuk.freeserve.co.uk/yar-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libsdl[sound,joystick,video]"
RDEPEND="${DEPEND}"
@@ -22,6 +22,7 @@ PATCHES=(
"${FILESDIR}"/${PV}-math.patch
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
)
src_install() {