summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-03-17 21:10:16 -0400
committerDavid Seifert <soap@gentoo.org>2017-03-25 13:47:41 +0100
commit313fde3785bcf2d23478b9780535cf0ecc81a8db (patch)
treed58030d8ad150f83ca003e1267d47608630f32bf /games-arcade
parentgames-puzzle/brainparty: Revbump for EAPI 6 support (diff)
downloadgentoo-313fde3785bcf2d23478b9780535cf0ecc81a8db.tar.gz
gentoo-313fde3785bcf2d23478b9780535cf0ecc81a8db.tar.bz2
gentoo-313fde3785bcf2d23478b9780535cf0ecc81a8db.zip
games-arcade/wop: Fix GCC-6 build
Bug: https://bugs.gentoo.org/show_bug.cgi?id=612526 Closes: https://github.com/gentoo/gentoo/pull/4222
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/wop/files/wop-0.4.3-gcc6.patch18
-rw-r--r--games-arcade/wop/wop-0.4.3-r1.ebuild3
2 files changed, 20 insertions, 1 deletions
diff --git a/games-arcade/wop/files/wop-0.4.3-gcc6.patch b/games-arcade/wop/files/wop-0.4.3-gcc6.patch
new file mode 100644
index 000000000000..add9e06c83a5
--- /dev/null
+++ b/games-arcade/wop/files/wop-0.4.3-gcc6.patch
@@ -0,0 +1,18 @@
+diff -Naur wop-0.4.3.old/src/global.cpp wop-0.4.3/src/global.cpp
+--- wop-0.4.3.old/src/global.cpp 2017-03-16 18:48:49.114967592 -0400
++++ wop-0.4.3/src/global.cpp 2017-03-16 18:48:55.592903512 -0400
+@@ -44,10 +44,10 @@
+ #define GREEN(s) s
+ #define RED(s) s
+ #else
+-#define BLACK(s) "\033[0;1m"s"\033[0m"
+-#define BLINKINK_BLACK_ON_RED(s) "\033[05;1;41m"s"\033[0m"
+-#define GREEN(s) "\033[32m"s"\033[0m"
+-#define RED(s) "\033[31m"s"\033[0m"
++#define BLACK(s) "\033[0;1m" s "\033[0m"
++#define BLINKINK_BLACK_ON_RED(s) "\033[05;1;41m" s "\033[0m"
++#define GREEN(s) "\033[32m" s "\033[0m"
++#define RED(s) "\033[31m" s "\033[0m"
+ #endif
+
+ /**********************************************************/
diff --git a/games-arcade/wop/wop-0.4.3-r1.ebuild b/games-arcade/wop/wop-0.4.3-r1.ebuild
index 48669c9e6520..9f6811a6fbec 100644
--- a/games-arcade/wop/wop-0.4.3-r1.ebuild
+++ b/games-arcade/wop/wop-0.4.3-r1.ebuild
@@ -37,7 +37,8 @@ src_prepare() {
woprc \
|| die "sed failed"
epatch "${FILESDIR}"/${P}-Makefile.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
}
src_compile() {