summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-07 12:54:23 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-07 12:54:23 +0200
commit35788251d79b5b511dab4ebd05c4da3377e92b33 (patch)
treef37ec1dd4b515c4797b57fc7be65961688d8e578 /games-arcade
parentdev-libs/opensc: Stabilize 0.22.0 arm, #843101 (diff)
downloadgentoo-35788251d79b5b511dab4ebd05c4da3377e92b33.tar.gz
gentoo-35788251d79b5b511dab4ebd05c4da3377e92b33.tar.bz2
gentoo-35788251d79b5b511dab4ebd05c4da3377e92b33.zip
games-arcade/supertux: fix GCC 12 build
Closes: https://bugs.gentoo.org/840269 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supertux/files/supertux-0.6.3-missing-include.patch10
-rw-r--r--games-arcade/supertux/supertux-0.6.3.ebuild10
2 files changed, 14 insertions, 6 deletions
diff --git a/games-arcade/supertux/files/supertux-0.6.3-missing-include.patch b/games-arcade/supertux/files/supertux-0.6.3-missing-include.patch
new file mode 100644
index 000000000000..4515c9a6003f
--- /dev/null
+++ b/games-arcade/supertux/files/supertux-0.6.3-missing-include.patch
@@ -0,0 +1,10 @@
+--- a/external/partio_zip/zip_manager.hpp
++++ b/external/partio_zip/zip_manager.hpp
+@@ -41,6 +41,7 @@
+ #ifndef __ZIP__
+ #define __ZIP__
+
++#include <memory>
+ #include <fstream>
+ #include <iostream>
+ #include <map>
diff --git a/games-arcade/supertux/supertux-0.6.3.ebuild b/games-arcade/supertux/supertux-0.6.3.ebuild
index 0a9fb27d74ef..173ea4e074c1 100644
--- a/games-arcade/supertux/supertux-0.6.3.ebuild
+++ b/games-arcade/supertux/supertux-0.6.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
#: ${CMAKE_MAKEFILE_GENERATOR:=emake}
-inherit cmake flag-o-matic
+inherit cmake
MY_PV="${PV/_rc/-rc.}"
MY_P="SuperTux-v${MY_PV}-Source"
@@ -12,6 +12,7 @@ MY_P="SuperTux-v${MY_PV}-Source"
DESCRIPTION="A game similar to Super Mario Bros"
HOMEPAGE="https://supertux.org/"
SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
SLOT="0"
@@ -41,16 +42,13 @@ BDEPEND="
virtual/pkgconfig
"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-0.5.0-tinygettext.patch
"${FILESDIR}"/${PN}-0.6.0-{license,icon,obstack}.patch
+ "${FILESDIR}"/${PN}-0.6.3-missing-include.patch
)
src_configure() {
- append-cxxflags -std=c++11
-
local mycmakeargs=(
-DWERROR=OFF
-DINSTALL_SUBDIR_BIN=bin