summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-28 02:46:06 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-28 12:42:38 -0400
commit3f663baaec4dcf0eaee3fcfc5dec7f2a31a37670 (patch)
tree5cfc168a37e1220cf0310b2f254ce42d81086103 /games-arcade
parentgames-arcade/missile: drop 1.0.1-r1 (diff)
downloadgentoo-3f663baaec4dcf0eaee3fcfc5dec7f2a31a37670.tar.gz
gentoo-3f663baaec4dcf0eaee3fcfc5dec7f2a31a37670.tar.bz2
gentoo-3f663baaec4dcf0eaee3fcfc5dec7f2a31a37670.zip
games-arcade/pengupop: EAPI 6->8, simplify ebuild
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch20
-rw-r--r--games-arcade/pengupop/pengupop-2.2.5-r1.ebuild53
2 files changed, 14 insertions, 59 deletions
diff --git a/games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch b/games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch
deleted file mode 100644
index fbbb704a6a30..000000000000
--- a/games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/Makefile.am.old 2011-06-14 21:44:40.242317771 +0200
-+++ b/Makefile.am 2011-06-14 21:44:49.216882568 +0200
-@@ -17,7 +17,7 @@
- nodist_pengupop_SOURCES = images.h
-
- if LINUX
--pengupop_LDADD = -lSDL -lz
-+pengupop_LDADD = -lSDL -lz -lm
-
- endif
- if WIN32
-@@ -25,7 +25,7 @@
- endif
- if DARWIN
- pengupop_LDFLAGS = -framework Carbon -framework CoreServices -framework AudioUnit -framework QuickTime -framework Cocoa -framework IOKit -framework OpenGL -framework SDL SDLMain.m
--pengupop_LDADD = -lz -lstdc++
-+pengupop_LDADD = -lz -lstdc++ -lm
-
- all-local: Pengupop.dmg
-
diff --git a/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
index 6938c534c5c9..c10d3f82d4a8 100644
--- a/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
+++ b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
@@ -1,55 +1,30 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools desktop gnome2-utils
+EAPI=8
-DESCRIPTION="Networked multiplayer-only Puzzle Bubble clone"
+inherit desktop
+
+DESCRIPTION="Networked Puzzle Bubble clone"
HOMEPAGE="http://freshmeat.net/projects/pengupop"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[sound,video]
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- eapply "${FILESDIR}"/${P}-underlink.patch
-
- sed -i \
- -e '/Icon/s/\.png//' \
- -e '/^Encoding/d' \
- -e '/Categories/s/Application;//' \
- pengupop.desktop || die
- sed -i \
- -e 's/-g -Wall -O2/-Wall/' \
- Makefile.am || die
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
- mv configure.in configure.ac || die
- eautoreconf
+src_compile() {
+ emake LIBS=-lm #497196
}
src_install() {
default
- domenu pengupop.desktop
- doicon -s 48 pengupop.png
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-pkg_postrm() {
- gnome2_icon_cache_update
+ doicon pengupop.png
+ make_desktop_entry ${PN} Pengupop
}