summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-14 21:17:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-15 16:00:20 -0400
commit467c360abf7822d6d964f417eacdec882dfbaaac (patch)
tree8b804a926ce2bfd2d851e1c1da95df0e11f2ba34 /games-arcade
parentgames-board/pasang-emas: restrict tests, tidy (diff)
downloadgentoo-467c360abf7822d6d964f417eacdec882dfbaaac.tar.gz
gentoo-467c360abf7822d6d964f417eacdec882dfbaaac.tar.bz2
gentoo-467c360abf7822d6d964f417eacdec882dfbaaac.zip
games-arcade/abe: tidy ebuild and add missing EPREFIX
src_unpack was only to extract a .bmp icon that is not XDG compliant (game itself reads the .tar directly) Also moved patch comments inside the patches themselves. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/abe/abe-1.1-r1.ebuild43
-rw-r--r--games-arcade/abe/files/abe-1.1-doublefree.patch6
-rw-r--r--games-arcade/abe/files/abe-1.1-format-security.patch5
-rw-r--r--games-arcade/abe/files/abe-1.1-format.patch6
-rw-r--r--games-arcade/abe/files/abe-1.1-settings.patch8
5 files changed, 30 insertions, 38 deletions
diff --git a/games-arcade/abe/abe-1.1-r1.ebuild b/games-arcade/abe/abe-1.1-r1.ebuild
index 0e3877c63b47..db902811eb95 100644
--- a/games-arcade/abe/abe-1.1-r1.ebuild
+++ b/games-arcade/abe/abe-1.1-r1.ebuild
@@ -13,53 +13,38 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="media-libs/libsdl[sound,video]
- x11-libs/libXi
- media-libs/sdl-mixer[vorbis]"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}" || die
- unpack ./images/images.tar
-}
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ x11-libs/libXi"
+DEPEND="${RDEPEND}"
PATCHES=(
- # From Fedora:
- # Enable changing the video settings. Sent upstream 2 Apr 2006:
- # https://sourceforge.net/p/abe/bugs/1/
"${FILESDIR}"/${P}-settings.patch
-
- # Fix a double free() bug. Sent upstream 15 Mar 2011:
- # https://sourceforge.net/p/abe/patches/1/
"${FILESDIR}"/${P}-doublefree.patch
-
- # Fix an incorrect printf format specifier. Sent upstream 15 Mar 2011:
- # https://sourceforge.net/p/abe/patches/2/
"${FILESDIR}"/${P}-format.patch
-
- # Fix build failure with -Werror=format-security
"${FILESDIR}"/${P}-format-security.patch
)
src_prepare() {
default
- sed -i \
- -e "/^TR_CFLAGS/d" \
- -e "/^TR_CXXFLAGS/d" \
- configure || die
+
+ sed -i '/^TR_CFLAGS/d;/^TR_CXXFLAGS/d' configure || die
}
src_configure() {
tc-export CC CXX
- econf --with-data-dir=/usr/share/${PN}
+
+ econf --with-data-dir="${EPREFIX}"/usr/share/${PN}
}
src_install() {
dobin src/abe
+
insinto /usr/share/${PN}
- doins -r images sounds maps
- newicon tom1.bmp abe.bmp
- make_desktop_entry abe "Abe's Amazing Adventure" /usr/share/pixmaps/abe.bmp
+ doins -r images maps sounds
+
+ make_desktop_entry abe "Abe's Amazing Adventure" applications-games
+
einstalldocs
}
diff --git a/games-arcade/abe/files/abe-1.1-doublefree.patch b/games-arcade/abe/files/abe-1.1-doublefree.patch
index ce7389d97100..82d49031844c 100644
--- a/games-arcade/abe/files/abe-1.1-doublefree.patch
+++ b/games-arcade/abe/files/abe-1.1-doublefree.patch
@@ -1,5 +1,7 @@
---- a/src/Main.c.orig 2005-03-05 09:20:04.000000000 -0700
-+++ b/src/Main.c 2011-03-14 10:08:31.846413904 -0600
+Fix a double free() bug. Sent upstream 15 Mar 2011:
+https://sourceforge.net/p/abe/patches/1/
+--- a/src/Main.c
++++ b/src/Main.c
@@ -35,8 +35,6 @@
for(i = 0; modes[i]; ++i)
printf("\t%d x %d\n", modes[i]->w, modes[i]->h);
diff --git a/games-arcade/abe/files/abe-1.1-format-security.patch b/games-arcade/abe/files/abe-1.1-format-security.patch
index ad88b4b60486..9f98b080f53d 100644
--- a/games-arcade/abe/files/abe-1.1-format-security.patch
+++ b/games-arcade/abe/files/abe-1.1-format-security.patch
@@ -1,5 +1,6 @@
---- ./src/Game.c.orig 2005-03-05 09:20:04.000000000 -0700
-+++ ./src/Game.c 2013-11-20 12:30:00.000000000 -0700
+Fix build failure with -Werror=format-security
+--- ./src/Game.c
++++ ./src/Game.c
@@ -6,21 +6,14 @@ Game game;
// path_sprintf should not be used by other .c files, as it does not fit for them.
diff --git a/games-arcade/abe/files/abe-1.1-format.patch b/games-arcade/abe/files/abe-1.1-format.patch
index 529534745712..eed86f83483d 100644
--- a/games-arcade/abe/files/abe-1.1-format.patch
+++ b/games-arcade/abe/files/abe-1.1-format.patch
@@ -1,5 +1,7 @@
---- a/src/MapIO.c.orig 2005-03-05 09:20:04.000000000 -0700
-+++ b/src/MapIO.c 2011-03-14 10:15:33.166949366 -0600
+Fix an incorrect printf format specifier. Sent upstream 15 Mar 2011:
+https://sourceforge.net/p/abe/patches/2/
+--- a/src/MapIO.c
++++ b/src/MapIO.c
@@ -93,7 +93,7 @@
// compression step 1: read compressed data from disk
// FIXME: what would be nicer is to only allocate as much mem as used on disk.
diff --git a/games-arcade/abe/files/abe-1.1-settings.patch b/games-arcade/abe/files/abe-1.1-settings.patch
index ea5809f7386a..c0471a03388a 100644
--- a/games-arcade/abe/files/abe-1.1-settings.patch
+++ b/games-arcade/abe/files/abe-1.1-settings.patch
@@ -1,6 +1,8 @@
-diff -Naur --exclude '*.swp' abe-1.1/src/Menu.c abe-1.1.new/src/Menu.c
---- abe-1.1/src/Menu.c 2005-03-05 08:20:04.000000000 -0800
-+++ abe-1.1.new/src/Menu.c 2006-04-02 15:04:37.000000000 -0700
+From Fedora:
+Enable changing the video settings.Sent upstream 2 Apr 2006:
+https://sourceforge.net/p/abe/bugs/1/
+--- a/src/Menu.c
++++ b/src/Menu.c
@@ -116,7 +116,7 @@
if(n == SOUND_ENABLED || n == MUSIC_ENABLED)
return sound_loaded;