summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-01 08:01:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-01 19:19:15 -0400
commit482c2764535184fffb3750c35c1f56b984d0d9f1 (patch)
tree24d3b70e2d99d22aedcee4311992cf30f1d2b6fd /games-arcade
parentgames-misc/nyancat: add 1.5.2, EAPI-7 (diff)
downloadgentoo-482c2764535184fffb3750c35c1f56b984d0d9f1.tar.gz
gentoo-482c2764535184fffb3750c35c1f56b984d0d9f1.tar.bz2
gentoo-482c2764535184fffb3750c35c1f56b984d0d9f1.zip
games-arcade/rockdodger: add 1.1.4
- make game usable (broken since games.eclass--, wrong assets path) - make executable setgid gamestat (...was setgid root) - removed patches, obsolete/upstreamed - prefix support - install package's .desktop, bigger icon, and man page - added missing [joystick] (bug #737688), and others to handle assets - seds removed (bug #711110), includes audio sed given can't reproduce and upstream still left it at 512 in 2020 Closes: https://bugs.gentoo.org/680584 Closes: https://bugs.gentoo.org/711110 Closes: https://bugs.gentoo.org/737688 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/rockdodger/Manifest1
-rw-r--r--games-arcade/rockdodger/rockdodger-1.1.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/games-arcade/rockdodger/Manifest b/games-arcade/rockdodger/Manifest
index 24cdb923e2c6..11d90d34984d 100644
--- a/games-arcade/rockdodger/Manifest
+++ b/games-arcade/rockdodger/Manifest
@@ -1 +1,2 @@
DIST rockdodger-0.6.0a.tar.gz 410223 BLAKE2B 5ccda4400468d6a7209adfdad3045773bf31581e34dfb77bff7d314ca9d9fa18e6c5a24996259782c002cf8ea611f92388c9ca46be4e0c7492a526421e8e8163 SHA512 d517cc844df21e8772b13d0226841a64bede0cc2f5461fb83d313f49cd99192dcf6af4597e3d1f3e1c60f578437e355ce665e0288415da803a503fb12d8462eb
+DIST rockdodger-1.1.4.tar.gz 1026184 BLAKE2B 08885155508adb878908d3cf9201c98cffded37dea051cb9a668ddb63891a19369648964f3f19d94b72a08626d3d1dea73686b190898d8b59c3b91805e08677c SHA512 542a8b5b1a9dc7fc8e61d3183c14c3f45952614f2e00f71383dfd42ddcf275cbc14520797d4555f2f19f354a4f1819d8527a587598c9dbc06a75b21643a8b019
diff --git a/games-arcade/rockdodger/rockdodger-1.1.4.ebuild b/games-arcade/rockdodger/rockdodger-1.1.4.ebuild
new file mode 100644
index 000000000000..6f4a73b078fd
--- /dev/null
+++ b/games-arcade/rockdodger/rockdodger-1.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Dodge the rocks for as long as possible until you die"
+HOMEPAGE="https://bitbucket.org/rpkrawczyk/rockdodger"
+SRC_URI="https://bitbucket.org/rpkrawczyk/rockdodger/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/gamestat
+ media-libs/libsdl[joystick,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod,wav]"
+DEPEND="${DEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ local emakeargs=(
+ prefix="${EPREFIX}"/usr
+ gamesdir="${EPREFIX}"/var/games/${PN}
+ MOREOPTS="${CFLAGS} ${CPPFLAGS}"
+ )
+ emake "${emakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.6
+
+ insinto /usr/share/${PN}
+ doins -r data/.
+
+ newicon ${PN}.icon.64x64.xpm ${PN}.xpm
+ domenu ${PN}.desktop
+
+ dodir /var/games/${PN}
+ touch "${ED}"/var/games/${PN}/${PN}.scores || die
+
+ fowners -R :gamestat /{usr/bin,var/games}/${PN}
+ fperms 660 /var/games/${PN}/${PN}.scores
+ fperms g+s /usr/bin/${PN}
+}