summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-03 01:13:30 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-03 01:56:15 -0400
commit5a2daa6ac21762b219d8b7fbd4a4fec3e7681403 (patch)
tree471240f681306395833f46bcc4c41e5a5b9e7e74 /games-arcade
parentmedia-sound/xmms2: add 0.9.1 (diff)
downloadgentoo-5a2daa6ac21762b219d8b7fbd4a4fec3e7681403.tar.gz
gentoo-5a2daa6ac21762b219d8b7fbd4a4fec3e7681403.tar.bz2
gentoo-5a2daa6ac21762b219d8b7fbd4a4fec3e7681403.zip
games-arcade/cdogs-sdl: add 1.3.0
Also add CC-BY-4.0 (lmg.mp3) and WTFPL-2 (easing.c) to LICENSE, and [mp3] to sdl2-mixer. Remove CMAKE_IN_SOURCE_BUILD workaround, no longer necessary. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/cdogs-sdl/Manifest1
-rw-r--r--games-arcade/cdogs-sdl/cdogs-sdl-1.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/games-arcade/cdogs-sdl/Manifest b/games-arcade/cdogs-sdl/Manifest
index b11570cc4d7e..b951604ba215 100644
--- a/games-arcade/cdogs-sdl/Manifest
+++ b/games-arcade/cdogs-sdl/Manifest
@@ -1 +1,2 @@
DIST cdogs-sdl-1.2.0.tar.gz 35018104 BLAKE2B 1a87f0c6e4af0fda69c0dd98249b319b58411a5b0b7377c21ebef51939f2b6e76959a00bf7fd5602b07bebb9eaab22c840699ae1c54e5d4dcb1aa26852fb8ba0 SHA512 70a5a4bb8e48cf53a4497807b14d8a70e26ad6b74f0c4675b3d98667c867d499d372f323e7abb669ebef08b1d6b5ac9c840ab14eada38e7b868d3099ed6b3e35
+DIST cdogs-sdl-1.3.0.tar.gz 35201522 BLAKE2B bdfeab22edc0e5bfe46d23862bb0e8a829eb8c782519f473340a73d6823fcf6236d61892dff5f6be52e985a8560ce2175b5aab50fb899359d47d3acdf937fe5d SHA512 913ee8a70ab2190259a88891e4f3e30034b7a88dac5fa1a79fcc9452a42fe9fa6679e24104848fab63c7aace8dac311d2166fa01c7175f14243d8658f25aee69
diff --git a/games-arcade/cdogs-sdl/cdogs-sdl-1.3.0.ebuild b/games-arcade/cdogs-sdl/cdogs-sdl-1.3.0.ebuild
new file mode 100644
index 000000000000..70ed391a2e22
--- /dev/null
+++ b/games-arcade/cdogs-sdl/cdogs-sdl-1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Classic overhead run-and-gun game"
+HOMEPAGE="https://cxong.github.io/cdogs-sdl/"
+SRC_URI="https://github.com/cxong/cdogs-sdl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD-2 CC-BY-3.0 CC-BY-4.0 CC-BY-SA-3.0 CC0-1.0 WTFPL-2 XMAME"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl2[haptic,opengl]
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[mp3,vorbis,wav]
+ net-libs/enet:1.3="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-cmake.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCDOGS_DATA_DIR="${EPREFIX}"/usr/share/${PN}/
+ -DBUILD_EDITOR=OFF
+ -DUSE_SHARED_ENET=ON
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc doc/{AUTHORS,original_readme.txt}
+
+ # CREDITS is used at runtime, rest is licenses or duplicates
+ find "${ED}"/usr/share/${PN}/doc -type f ! -name CREDITS -delete || die
+}