summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-05 23:55:00 +0000
committerSam James <sam@gentoo.org>2021-03-05 23:55:00 +0000
commit845877776a48aee97f7ae414c262630e331efb52 (patch)
treefa3fa9dba7b6d718e33d8b75cb1006351ff7aa99 /games-arcade
parentgames-arcade/jumpnbump: 1.61 version bump (diff)
downloadgentoo-845877776a48aee97f7ae414c262630e331efb52.tar.gz
gentoo-845877776a48aee97f7ae414c262630e331efb52.tar.bz2
gentoo-845877776a48aee97f7ae414c262630e331efb52.zip
games-arcade/jumpnbump: misc fixups
* + Python 3.9 * - Python 3.6 * GCC 10 workaround Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/jumpnbump/jumpnbump-1.61.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/games-arcade/jumpnbump/jumpnbump-1.61.ebuild b/games-arcade/jumpnbump/jumpnbump-1.61.ebuild
index 4681c057d6cd..d7aafa39634f 100644
--- a/games-arcade/jumpnbump/jumpnbump-1.61.ebuild
+++ b/games-arcade/jumpnbump/jumpnbump-1.61.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit python-single-r1 flag-o-matic toolchain-funcs
DESCRIPTION="A funny multiplayer game about cute little fluffy bunnies"
HOMEPAGE="https://libregames.gitlab.io/jumpnbump"
@@ -21,7 +22,8 @@ DEPEND="
media-libs/libsdl2
media-libs/sdl2-net
"
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
gtk? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
@@ -33,6 +35,10 @@ RDEPEND="${DEPEND}
"
src_compile() {
+ tc-export AR CC RANLIB
+
+ append-flags -fcommon
+
emake PREFIX="${EPREFIX}/usr"
use gtk && emake PREFIX="${EPREFIX}/usr" jnbmenu
}