summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-21 08:26:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-21 09:07:56 -0400
commit85d77cfc21b16728b93fc76b92dcba52b7fcfa26 (patch)
treeb9b5e307fb27599e71236fcb71a2acc3a4c1b528 /games-arcade
parentgames-arcade/solarwolf: drop 1.5-r2 (diff)
downloadgentoo-85d77cfc21b16728b93fc76b92dcba52b7fcfa26.tar.gz
gentoo-85d77cfc21b16728b93fc76b92dcba52b7fcfa26.tar.bz2
gentoo-85d77cfc21b16728b93fc76b92dcba52b7fcfa26.zip
games-arcade/whichwayisup: EAPI 7->8, various fixes
- python-r1 -> python-single-r1 wrt bug #710234 - don't call python directly - add missing sdl2 deps - remove homepage, gone with no official replacement could find Also replaced icon from files/, xpm may be text-only but filling the tree with an old uncompressed text image format doesn't sound right. Closes: https://bugs.gentoo.org/710234 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/whichwayisup/Manifest1
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.9-r4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/games-arcade/whichwayisup/Manifest b/games-arcade/whichwayisup/Manifest
index 909f726905b9..457e7350e5f4 100644
--- a/games-arcade/whichwayisup/Manifest
+++ b/games-arcade/whichwayisup/Manifest
@@ -1 +1,2 @@
+DIST whichwayisup.png 6720 BLAKE2B 26514e025341ce7d5145d69295a24477ea3575afcfb0a11bbbddb1dd716feadef9a030ec9dc4171b75842fafc78670ed1fc7656dac8dbd6695b9592b73bb1383 SHA512 469b847955a745177c7629dd13f1975191766863bfe263e3818105356d71aaaeb66cbe34846d0bd908bf494e2d7d42b7f33499868da2fa346f96f8080bccc0b2
DIST whichwayisup_b079.zip 1001890 BLAKE2B bfc8f15376ae7c93cc3921a7c0537d44bca44cbfd5e19533912c56151b8811a40e96271e0f3b8634a6fc4625bd32c9668fc3c321f1d2ea0306517067f3d31e24 SHA512 49ac6b8224f3cf7b0711b297c9dd96ff2a0969f7c16fa1da500bef1ea5d793bd900be124a9b9874239c98db6fd2db92917b8ce2ee09b685e184cfd87bf519809
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.9-r4.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.9-r4.ebuild
new file mode 100644
index 000000000000..f37eff3578bc
--- /dev/null
+++ b/games-arcade/whichwayisup/whichwayisup-0.7.9-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit desktop python-single-r1
+
+DESCRIPTION="Traditional and challenging 2D platformer game with a slight rotational twist"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="
+ mirror://gentoo/${PN}_b$(ver_rs 1- '').zip
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+S="${WORKDIR}/${PN}"
+
+LICENSE="BitstreamVera CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygame[${PYTHON_USEDEP}]')
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-check_for_joystick_axes_not_null.patch
+ "${FILESDIR}"/${P}-initialize_only_required_pygame_modules.patch
+ "${FILESDIR}"/${P}-python3.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "/libdir =/s|= .*|= \"${EPREFIX}/usr/share/${PN}/lib\"|" run_game.py || die
+ python_fix_shebang run_game.py
+
+ rm data/pictures/Thumbs.db || die
+}
+
+src_install() {
+ newbin run_game.py ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r data lib
+
+ dodoc README.txt changelog.txt
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} "Which Way Is Up?"
+}