summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-27 22:34:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-28 12:42:37 -0400
commitaa1d52980fad84ee276783a82a14e56316551b5b (patch)
treebddfeaf0312ca6299c84672a0d28ecdf3fc1ec64 /games-arcade
parentgames-arcade/lbreakout: fix install, EAPI 6->8, tidy (diff)
downloadgentoo-aa1d52980fad84ee276783a82a14e56316551b5b.tar.gz
gentoo-aa1d52980fad84ee276783a82a14e56316551b5b.tar.bz2
gentoo-aa1d52980fad84ee276783a82a14e56316551b5b.zip
games-arcade/lbreakout2: fix qa notice, add unzip dep, tidy
Use /var/games for highscore file instead of /var/lib/*.hscr and use gamestat for bug #683052. Also removed -O? filter, been there since 2003 and never explained. No issues with modern compilers and various -O levels Closes: https://bugs.gentoo.org/683052 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/lbreakout2/lbreakout2-2.6.5-r2.ebuild (renamed from games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild)77
1 files changed, 39 insertions, 38 deletions
diff --git a/games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild b/games-arcade/lbreakout2/lbreakout2-2.6.5-r2.ebuild
index 4f0c9cc48e96..d96256696ace 100644
--- a/games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild
+++ b/games-arcade/lbreakout2/lbreakout2-2.6.5-r2.ebuild
@@ -1,94 +1,95 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop flag-o-matic gnome2-utils
+inherit autotools desktop
-levels_V=20141220
-themes_V=20141220
+LB_LEVELS_V="20141220"
+LB_THEMES_V="20141220"
DESCRIPTION="Breakout clone written with the SDL library"
HOMEPAGE="http://lgames.sourceforge.net/LBreakout2/"
-SRC_URI=" mirror://sourceforge/lgames/${P}.tar.gz
- mirror://sourceforge/lgames/add-ons/lbreakout2/${PN}-levelsets-${levels_V}.tar.gz
- themes? ( mirror://sourceforge/lgames/add-ons/lbreakout2/${PN}-themes-${levels_V}.tar.gz )"
+SRC_URI="
+ mirror://sourceforge/lgames/${P}.tar.gz
+ mirror://sourceforge/lgames/add-ons/lbreakout2/${PN}-levelsets-${LB_LEVELS_V}.tar.gz
+ themes? ( mirror://sourceforge/lgames/add-ons/lbreakout2/${PN}-themes-${LB_LEVELS_V}.tar.gz )"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls themes"
RDEPEND="
- media-libs/libpng:0=
- sys-libs/zlib
- media-libs/libsdl[sound,joystick,video]
- media-libs/sdl-net
+ acct-group/gamestat
+ media-libs/libpng:=
+ media-libs/libsdl[joystick,sound,video]
media-libs/sdl-mixer
+ media-libs/sdl-net
nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}"
-BDEPEND="nls? ( sys-devel/gettext )"
+DEPEND="
+ ${RDEPEND}
+ sys-libs/zlib"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ themes? ( app-arch/unzip )"
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
src_unpack() {
unpack ${P}.tar.gz
cd "${S}/client/levels" || die
- unpack ${PN}-levelsets-${levels_V}.tar.gz
+ unpack ${PN}-levelsets-${LB_LEVELS_V}.tar.gz
if use themes; then
mkdir "${WORKDIR}"/themes || die
cd "${WORKDIR}"/themes || die
- unpack ${PN}-themes-${themes_V}.tar.gz
+ unpack ${PN}-themes-${LB_THEMES_V}.tar.gz
# Delete a few duplicate themes (already shipped with lbreakout2
# tarball). Some of them have different case than built-in themes, so it
# is harder to just compare if the filename is the same.
- rm -f absoluteB.zip oz.zip moiree.zip || die
+ rm absoluteB.zip oz.zip moiree.zip || die
local f
for f in *.zip; do
- unzip -q "${f}" || die
- rm -f "${f}" || die
+ unpack ./${f}
+ rm ${f} || die
done
fi
}
src_prepare() {
default
+
mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- filter-flags -O?
- econf \
- --enable-sdl-net \
- --with-docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ local econfargs=(
$(use_enable nls)
+ --enable-sdl-net
+ --localstatedir="${EPREFIX}"/var/games
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ econf "${econfargs[@]}"
}
src_install() {
default
+ fowners :gamestat /usr/bin/${PN} /var/games/${PN}.hscr
+ fperms g+s /usr/bin/${PN}
+ fperms 660 /var/games/${PN}.hscr
+
if use themes; then
insinto /usr/share/lbreakout2/gfx
doins -r "${WORKDIR}"/themes/.
fi
newicon client/gfx/win_icon.png ${PN}.png
- newicon -s 32 client/gfx/win_icon.png ${PN}.png
- make_desktop_entry lbreakout2 LBreakout2
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
+ make_desktop_entry ${PN} LBreakout2
}