summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-23 13:23:40 +0100
committerSam James <sam@gentoo.org>2022-10-23 15:27:19 +0100
commitabcc335453aa5061c1c49ce92a08415568a0ec68 (patch)
tree192f5c22c2fc79e9e1ba0f278e791d180c9256dc /games-arcade
parentnet-misc/rclone: 1.60.0 version bump. (diff)
downloadgentoo-abcc335453aa5061c1c49ce92a08415568a0ec68.tar.gz
gentoo-abcc335453aa5061c1c49ce92a08415568a0ec68.tar.bz2
gentoo-abcc335453aa5061c1c49ce92a08415568a0ec68.zip
games-arcade/spout: fix build w/ Clang 16
Closes: https://bugs.gentoo.org/875722 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch30
-rw-r--r--games-arcade/spout/spout-1.3-r2.ebuild (renamed from games-arcade/spout/spout-1.3-r1.ebuild)7
2 files changed, 35 insertions, 2 deletions
diff --git a/games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch b/games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch
new file mode 100644
index 000000000000..644166e914ab
--- /dev/null
+++ b/games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch
@@ -0,0 +1,30 @@
+From d2382ee06a8f9feb9bed39bf592ad88b5c02bbf6 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 23 Oct 2022 13:21:55 +0100
+Subject: [PATCH] Fix implicit function declarations
+
+Bug: https://bugs.gentoo.org/875722
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/piece.c
++++ b/piece.c
+@@ -15,6 +15,10 @@ int zoom, fullscreen;
+
+ unsigned char *vBuffer = NULL;
+
++void pceAppInit (void);
++void pceAppExit (void);
++int pceAppProc (int cnt);
++
+ void
+ pceLCDDispStop ()
+ {
+--- a/spout.c
++++ b/spout.c
+@@ -80,6 +80,7 @@ void sweep (unsigned char c1, unsigned char c2);
+ void initGrain (void);
+ GRAIN *allocGrain (void);
+ GRAIN *freeGrain (GRAIN * current);
++void pceAppInit (void);
+
+ #ifdef HAVE_WORDEXP_H
+ wordexp_t *scorefile;
diff --git a/games-arcade/spout/spout-1.3-r1.ebuild b/games-arcade/spout/spout-1.3-r2.ebuild
index 2057b0f1b3be..9ed65f4f461f 100644
--- a/games-arcade/spout/spout-1.3-r1.ebuild
+++ b/games-arcade/spout/spout-1.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${PN}-1.3-Fix-implicit-function-declarations.patch
+)
src_install() {
dobin spout