summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-21 20:32:29 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-21 20:32:42 +0200
commitadae1da7e68b72370a7a506543928a1a650e48cc (patch)
tree39031d887f2909bbf8a51e449028503c36de5990 /games-arcade
parentdev-util/ltrace: use ${CXX} instead of c++ for tests (diff)
downloadgentoo-adae1da7e68b72370a7a506543928a1a650e48cc.tar.gz
gentoo-adae1da7e68b72370a7a506543928a1a650e48cc.tar.bz2
gentoo-adae1da7e68b72370a7a506543928a1a650e48cc.zip
games-arcade/blobwars: Fix music and import fixes from other distros
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/blobwars/blobwars-2.00-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-arcade/blobwars/blobwars-2.00-r1.ebuild b/games-arcade/blobwars/blobwars-2.00-r1.ebuild
new file mode 100644
index 000000000000..1d51f12f8b9d
--- /dev/null
+++ b/games-arcade/blobwars/blobwars-2.00-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils xdg
+
+DESCRIPTION="Platform game about a blob and his quest to rescue MIAs from an alien invader"
+HOMEPAGE="https://sourceforge.net/projects/blobwars/ https://www.parallelrealities.co.uk/games/metalBlobSolid/ https://github.com/perpendicular-dimensions/blobwars"
+SRC_URI="mirror://sourceforge/blobwars/${P}.tar.gz"
+
+LICENSE="BSD CC-BY-SA-3.0 CC-BY-3.0 GPL-2 LGPL-2.1 fairuse public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+ media-libs/sdl2-image
+ media-libs/sdl2-net
+ sys-libs/zlib
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ default
+
+ # Fixes from Fedora and OpenSuSE
+ sed -i -e 's|$(PREFIX)/games|$(PREFIX)/bin|;
+ s|$(PREFIX)/share/games|$(PREFIX)/share|;
+ s| -Werror||;
+ s|$(CXX) $(LIBS) $(GAMEOBJS) -o $(PROG)|$(CXX) $(GAMEOBJS) $(LIBS) -o $(PROG)|;
+ s|$(CXX) $(LIBS) $(PAKOBJS) -o pak|$(CXX) $(PAKOBJS) $(LIBS) -o pak|;
+ s|$(CXX) $(LIBS) $(MAPOBJS) -o mapeditor|$(CXX) $(MAPOBJS) $(LIBS) -o mapeditor|' \
+ Makefile || die
+ sed -i -e 's|gzclose(pak)|gzclose((gzFile)pak)|;
+ s|gzclose(fp)|gzclose((gzFile)fp)|' src/pak.cpp || die
+}
+
+src_compile() {
+ # USEPAK=1 breaks music
+ emake \
+ RELEASE="1" \
+ USEPAK="0"
+}
+
+src_install() {
+ emake \
+ BINDIR="/usr/bin/" \
+ USEPAK="0" \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}/html/" \
+ install
+
+ mv -vf \
+ "${D}"/usr/share/doc/${PF}/html/{changes,hacking,porting,readme} \
+ "${D}"/usr/share/doc/${PF}/
+}