summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 20:14:08 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:26:09 +0200
commite6cccc31a7dddee26a2a6cdb709af5721da04835 (patch)
tree2af409aa42cf766d4ad0c3a3df60d0643447fa73 /games-arcade
parentgames-arcade/solarwolf: Drop old (diff)
downloadgentoo-e6cccc31a7dddee26a2a6cdb709af5721da04835.tar.gz
gentoo-e6cccc31a7dddee26a2a6cdb709af5721da04835.tar.bz2
gentoo-e6cccc31a7dddee26a2a6cdb709af5721da04835.zip
games-arcade/spacerider: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-font.patch4
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc41.patch4
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc49.patch8
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gentoo.patch4
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch4
-rw-r--r--games-arcade/spacerider/spacerider-0.13-r1.ebuild44
6 files changed, 56 insertions, 12 deletions
diff --git a/games-arcade/spacerider/files/spacerider-0.13-font.patch b/games-arcade/spacerider/files/spacerider-0.13-font.patch
index 914a0466c7fe..87732a106633 100644
--- a/games-arcade/spacerider/files/spacerider-0.13-font.patch
+++ b/games-arcade/spacerider/files/spacerider-0.13-font.patch
@@ -1,8 +1,8 @@
Ugly brute-force method for avoiding a double-free segfault on exit.
Better patch welcome.
---- spacerider.cpp.orig 2015-03-31 23:24:17.770966147 -0400
-+++ spacerider.cpp 2015-03-31 23:24:41.592174463 -0400
+--- a/spacerider.cpp.orig 2015-03-31 23:24:17.770966147 -0400
++++ b/spacerider.cpp 2015-03-31 23:24:41.592174463 -0400
@@ -306,8 +306,6 @@
/* free screen */
SDL_FreeSurface(screen);
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
index 1a08d715ac5b..e5524b6e6430 100644
--- a/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
+++ b/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
@@ -1,5 +1,5 @@
---- spacerider.cpp.old 2007-02-18 11:25:38.000000000 +0100
-+++ spacerider.cpp 2007-02-18 11:27:00.000000000 +0100
+--- a/spacerider.cpp.old 2007-02-18 11:25:38.000000000 +0100
++++ b/spacerider.cpp 2007-02-18 11:27:00.000000000 +0100
@@ -17,6 +17,7 @@
#include <unistd.h>
}
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
index d057e7bab730..b4d5ca6d5764 100644
--- a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
+++ b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
@@ -1,5 +1,5 @@
---- effect.cpp.orig 2015-03-31 22:36:53.336131373 -0400
-+++ effect.cpp 2015-03-31 22:37:04.359755281 -0400
+--- a/effect.cpp.orig 2015-03-31 22:36:53.336131373 -0400
++++ b/effect.cpp 2015-03-31 22:37:04.359755281 -0400
@@ -18,7 +18,7 @@
void Effect::add(const int x, const int y)
{
@@ -9,8 +9,8 @@
{
return;
}
---- object.h.orig 2015-03-31 22:35:22.939214561 -0400
-+++ object.h 2015-03-31 22:37:19.654233441 -0400
+--- a/object.h.orig 2015-03-31 22:35:22.939214561 -0400
++++ b/object.h 2015-03-31 22:37:19.654233441 -0400
@@ -172,7 +172,7 @@
return object->next;
}
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
index d692f87632b0..ecfdcc513cd0 100644
--- a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
+++ b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -3,12 +3,12 @@
BINDIR=/usr/bin/
MANDIR=/usr/share/man/man1/
diff --git a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
index 5ed73c348cf2..c590400f649f 100644
--- a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
+++ b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
@@ -1,5 +1,5 @@
---- spacerider.cpp.old 2010-10-29 10:12:19.000000000 +0200
-+++ spacerider.cpp 2010-10-29 10:13:47.000000000 +0200
+--- a/spacerider.cpp.old 2010-10-29 10:12:19.000000000 +0200
++++ b/spacerider.cpp 2010-10-29 10:13:47.000000000 +0200
@@ -112,7 +112,7 @@
break;
case 'n':
diff --git a/games-arcade/spacerider/spacerider-0.13-r1.ebuild b/games-arcade/spacerider/spacerider-0.13-r1.ebuild
new file mode 100644
index 000000000000..8cf24d976f7d
--- /dev/null
+++ b/games-arcade/spacerider/spacerider-0.13-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Space-shooter written in C++, using the SDL"
+HOMEPAGE="http://www.hackl.dhs.org/spacerider/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2" # stupid php script
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-mixer
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-net
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}"-gentoo.patch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-gcc49.patch \
+ "${FILESDIR}"/${P}-font.patch
+ sed -i \
+ -e "s:/usr/share/games/spacerider:/usr/share/${PN}:" \
+ globals.cpp || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto "/usr/share/${PN}"
+ doins -r data
+ einstalldocs
+ newman ${PN}.{1,6}
+ newicon data/sprites/star_monster1/1.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Spacerider /usr/share/pixmaps/${PN}.bmp
+}