summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-19 01:30:44 +0100
committerSam James <sam@gentoo.org>2021-08-19 01:39:06 +0100
commitf2ec3cbe2eed9382c90e01e43c9563b419c38b34 (patch)
tree4feb4cbf8df6077b8a054d324dfd23e0887ed24d /games-arcade
parentgames-puzzle/mures: add missing libsdl[joystick] dependency (diff)
downloadgentoo-f2ec3cbe2eed9382c90e01e43c9563b419c38b34.tar.gz
gentoo-f2ec3cbe2eed9382c90e01e43c9563b419c38b34.tar.bz2
gentoo-f2ec3cbe2eed9382c90e01e43c9563b419c38b34.zip
games-arcade/opentyrian: fix libsdl[joystick] dependency
Closes: https://bugs.gentoo.org/740354 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opentyrian/files/2.1.20130907-datapath.diff26
-rw-r--r--games-arcade/opentyrian/files/opentyrian-2.1.20130907-cflags.patch (renamed from games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff)5
-rw-r--r--games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch24
-rw-r--r--games-arcade/opentyrian/files/opentyrian-2.1.20130907-gcc10.patch (renamed from games-arcade/opentyrian/files/2.1.20130907-gcc10.patch)9
-rw-r--r--games-arcade/opentyrian/opentyrian-2.1.20130907-r2.ebuild11
5 files changed, 32 insertions, 43 deletions
diff --git a/games-arcade/opentyrian/files/2.1.20130907-datapath.diff b/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
deleted file mode 100644
index 5b0143ed9a50..000000000000
--- a/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -uNr opentyrian-2.1.20130907.ORIG/Makefile opentyrian-2.1.20130907/Makefile
---- opentyrian-2.1.20130907.ORIG/Makefile 2013-12-08 17:40:23.470846371 +0000
-+++ opentyrian-2.1.20130907/Makefile 2013-12-08 17:40:49.355847165 +0000
-@@ -49,6 +49,10 @@
- ALL_LDFLAGS += $(LDFLAGS)
- LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
-
-+ifneq ($(DATA_PATH), )
-+ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
-+endif
-+
- # RULES ####################################################
-
- .PHONY : all release clean
-diff -uNr opentyrian-2.1.20130907.ORIG/src/file.c opentyrian-2.1.20130907/src/file.c
---- opentyrian-2.1.20130907.ORIG/src/file.c 2013-12-08 17:40:23.468846371 +0000
-+++ opentyrian-2.1.20130907/src/file.c 2013-12-08 17:40:49.355847165 +0000
-@@ -34,7 +34,7 @@
- #ifdef TARGET_MACOSX
- tyrian_game_folder(),
- #endif
-- "/usr/share/opentyrian/data"
-+ DATA_PATH
- };
-
- static const char *dir = NULL;
diff --git a/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-cflags.patch
index 39ccf1c79f66..3654e22ef45e 100644
--- a/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff
+++ b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-cflags.patch
@@ -1,6 +1,5 @@
-diff -uNr opentyrian-2.1.20130907.ORIG/Makefile opentyrian-2.1.20130907/Makefile
---- opentyrian-2.1.20130907.ORIG/Makefile 2013-12-08 17:38:06.982842189 +0000
-+++ opentyrian-2.1.20130907/Makefile 2013-12-08 17:38:26.843842798 +0000
+--- a/Makefile
++++ b/Makefile
@@ -21,11 +21,6 @@
# FLAGS ####################################################
diff --git a/games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch
new file mode 100644
index 000000000000..8ebf427d0797
--- /dev/null
+++ b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -49,6 +49,10 @@
+ ALL_LDFLAGS += $(LDFLAGS)
+ LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all release clean
+--- a/src/file.c
++++ b/src/file.c
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;
diff --git a/games-arcade/opentyrian/files/2.1.20130907-gcc10.patch b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-gcc10.patch
index 5b0c911a2ac2..6f0bfcf64cf3 100644
--- a/games-arcade/opentyrian/files/2.1.20130907-gcc10.patch
+++ b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-gcc10.patch
@@ -4,13 +4,6 @@ Date: Sun, 14 Jun 2020 14:11:00 -0600
Subject: [PATCH] Move definitions that don't need to be exposed from opl.h to
opl.c
----
- src/opl.c | 153 +++++++++++++++++++++++++++++++++++++++++++++++++++-
- src/opl.h | 157 ++----------------------------------------------------
- 2 files changed, 154 insertions(+), 156 deletions(-)
-
-diff --git a/src/opl.c b/src/opl.c
-index a4071c5..f15474c 100644
--- a/src/opl.c
+++ b/src/opl.c
@@ -23,12 +23,161 @@
@@ -177,8 +170,6 @@ index a4071c5..f15474c 100644
static Bit32u generator_add; // should be a chip parameter
-diff --git a/src/opl.h b/src/opl.h
-index c8e643b..cbb56ad 100644
--- a/src/opl.h
+++ b/src/opl.h
@@ -25,11 +25,8 @@
diff --git a/games-arcade/opentyrian/opentyrian-2.1.20130907-r2.ebuild b/games-arcade/opentyrian/opentyrian-2.1.20130907-r2.ebuild
index 74fce946ff85..1161edc3135f 100644
--- a/games-arcade/opentyrian/opentyrian-2.1.20130907-r2.ebuild
+++ b/games-arcade/opentyrian/opentyrian-2.1.20130907-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,19 +14,20 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="media-libs/libsdl[video]
+DEPEND="media-libs/libsdl[joystick,video]
media-libs/sdl-net"
RDEPEND="${DEPEND}"
BDEPEND="app-arch/unzip"
PATCHES=(
- "${FILESDIR}/${PV}-datapath.diff"
- "${FILESDIR}/${PV}-cflag-idiocy.diff"
- "${FILESDIR}/${PV}-gcc10.patch"
+ "${FILESDIR}/${P}-datapath.patch"
+ "${FILESDIR}/${P}-cflags.patch"
+ "${FILESDIR}/${P}-gcc10.patch"
)
src_prepare() {
default
+
rm "${WORKDIR}"/tyrian21/{*.exe,dpmi16bi.ovl,loudness.awe} || die "Failed to remove win32 binaries"
}