summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/awale/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/awale/files')
-rw-r--r--games-board/awale/files/awale-1.5-build.patch116
1 files changed, 116 insertions, 0 deletions
diff --git a/games-board/awale/files/awale-1.5-build.patch b/games-board/awale/files/awale-1.5-build.patch
new file mode 100644
index 000000000000..0e8ca136a410
--- /dev/null
+++ b/games-board/awale/files/awale-1.5-build.patch
@@ -0,0 +1,116 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat Jan 26 20:04:17 UTC 2013
+Subject: build system
+
+ fix FHS compliance
+ add several switches for icon, desktopdir and tk
+ fix a few macros
+
+--- awale-1.5/src/Makefile.am
++++ awale-1.5/src/Makefile.am
+@@ -1,24 +1,30 @@
+ bin_PROGRAMS = awale
+ awale_SOURCES = awale.c getopt.c getopt1.c getopt.h
+-INCLUDES = -I. -I$(srcdir)
++AM_CPPFLAGS = -I. -I$(srcdir)
++
++if TK_GUI
+ bin_SCRIPTS = xawale
+ xawale:
+ echo "#! /bin/sh" >$@
+- echo '`dirname $$0`/../share/awale/xawale.tcl' >>$@
++ echo "cd \"$(datadir)/awale/\" ; exec \"$(datadir)/awale/xawale.tcl\"" >>$@
+ chmod ugo+x $@
+-appdir = $(prefix)/share/applications
++appdir = @DESKTOPFILESDIR@
+ app_DATA = awale.desktop
+ awale.desktop:
+ echo "[Desktop Entry]" >$@
+ echo "Name=Free Awale" >>$@
+ echo "Comment=Awale game" >>$@
+ echo "Exec=xawale" >>$@
+- echo 'Icon=$(pkgdatadir)/awale.png' >>$@
++ echo 'Icon=awale' >>$@
+ echo "Terminal=false" >>$@
+ echo "Type=Application" >>$@
+ echo "Categories=Game;BoardGame;" >>$@
+ chmod 644 $@
+ CLEANFILES = xawale awale.desktop
++
++xawale.tcl:
++ sed 's|@my_bindir@|$(bindir)|' < $@.in > $@
++
+ pkgdata_SCRIPTS = xawale.tcl
+ dist_pkgdata_DATA = Trou00.gif Trou01.gif Trou02.gif Trou03.gif Trou04.gif Trou05.gif \
+ Trou06.gif Trou07.gif Trou08.gif Trou09.gif Trou10.gif Trou11.gif \
+@@ -28,3 +34,8 @@
+ Trou06.gif Trou07.gif Trou08.gif Trou09.gif Trou10.gif Trou11.gif \
+ Trou12.gif Trou13.gif Trou14.gif Trou15.gif board.gif copyright.gif \
+ awale.png awale.ico uk.gif fr.gif sp.gif AwaleBanner.bmp README
++
++# icon
++iconsdir = @ICONSDIR@
++dist_icons_DATA = awale.png
++endif
+--- awale-1.5/configure.in
++++ awale-1.5/configure.in
+@@ -1,6 +1,34 @@
+-AC_INIT(awale.c)
+-AM_INIT_AUTOMAKE(awale, 1.5)
++AC_INIT([awale], [1.5])
++AM_INIT_AUTOMAKE([-Wall])
+ AC_CONFIG_SRCDIR([src/awale.c])
+ AC_PROG_CC
++
++
++# let user specify desktopdir
++AC_ARG_WITH([desktopdir],
++ [AS_HELP_STRING([--with-desktopdir=DIR],
++ [path where desktop files get installed (default: $datadir/applications)])],
++ [DESKTOPFILESDIR="$withval"],
++ [DESKTOPFILESDIR='$(datadir)/applications'])
++
++# let user specify iconsdir
++AC_ARG_WITH([iconsdir],
++ [AS_HELP_STRING([--with-iconsdir=DIR],
++ [path where icons get installed (default: $datadir/pixmaps)])],
++ [ICONSDIR="$withval"],
++ [ICONSDIR='$(datadir)/pixmaps'])
++
++# configure-switch for tkgui
++AC_ARG_ENABLE([tk],
++ [AS_HELP_STRING([--enable-tk],
++ [enable tk gui (default: enable)])],
++ [enable_tk=$enableval],
++ [enable_tk="no"])
++
++AM_CONDITIONAL([TK_GUI], [test "x$enable_tk" = "xyes"])
++
++AC_SUBST([ICONSDIR])
++AC_SUBST([DESKTOPFILESDIR])
++
+ AC_CONFIG_FILES([Makefile src/Makefile man/Makefile])
+ AC_OUTPUT
+
+--- awale-1.5/man/Makefile.am
++++ awale-1.5/man/Makefile.am
+@@ -1,3 +1,7 @@
+-mandir = $(prefix)/share/man
++if TK_GUI
+ man_MANS = awale.6 xawale.6
++else
++man_MANS = awale.6
++endif
++
+ EXTRA_DIST = $(man_MANS)
+--- awale-1.5/src/xawale.tcl
++++ awale-1.5/src/xawale.tcl
+@@ -693,7 +693,7 @@
+
+ switch $tcl_platform(platform) {
+ "unix" {
+- set JOUER [file join [file dirname [info script]] .. .. bin awale]
++ set JOUER "@my_bindir@/awale"
+ }
+ "macintosh" {
+ set JOUER [file join [file dirname [info script]] .. .. bin awale]